Lightroom: Cannot use keyboard shortcuts on non-english keyboard

  • 17
  • Problem
  • Updated 6 months ago
  • (Edited)
Obviously Adobe is not aware that there are different keyboard-layouts around the world. On my layout (swiss) the # can only be accessed by "Alt Gr"+3 (Ctrl+Alt+3"). That # is used very often in Lightroom and I cannot use these preset shortkeys - unfortunately they can't be changed (like in Photoshop where I changed the presets). Would be great if I could either change the shortkeys or Adobe uses shortkeys that can be used all over the world (Italy and Spain has the same problem with the # btw.)

http://en.wikipedia.org/wiki/Keyboard...
Photo of Michelle Brügger

Michelle Brügger

  • 3 Posts
  • 0 Reply Likes
  • a bit annoyed

Posted 7 years ago

  • 17
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 38 Reply Likes
Michelle,

There is a workaround for that, which is not elegant but works OK:


  • In the folder where LR is installed, you'll find a folder /resources/de/, with a file called TranslatedStrings.txt in it

  • Create a backup-copy of the file TranslatedStrings.txt

  • Edit the file TranslatedStrings.txt with a text editor, replacing the # by something else which does not require a modifier key (I use $) on all lines which seem relevant to you.

  • Make a note of the changes you made (and possibly keep a copy of the modified file TranslatedStrings.txt in some other folder also), as this will be overwritten with a new installation of LR



These are the lines I changed for myself in TranslatedStrings.txt:

"$$$/AgApplication/Menu/Window/SecondMonitor/ZoomInShortcut=Cmd+Shift+#"
"$$$/AgApplication/Menu/Window/SecondMonitor/ZoomInSomeShortcut=Flippy+Cmd+Option+Shift+#"
"$$$/AgCameraRawController/TargetAdjustment/Bezel=^1 mit Tasten # / - ändern"
"$$$/AgCameraRawController/TargetAdjustment/BezelWithMinusSignGlyph=^1 mit Tasten # / ^U+2212 ändern"
"$$$/AgDevelop/KBSC/incrementTargetAdjustmentValue=#"
"$$$/AgDevelop/Menu/View/ZoomIn/Key=Cmd+#"
"$$$/AgDevelop/Menu/View/ZoomInMinor/Key=Cmd+Option+#"
"$$$/AgLibrary/Help/Shortcuts/Zoom_in/Key=Befehl + #"
"$$$/AgLibrary/KBSC/incrementThumbSize=#"
"$$$/AgLibrary/Menu/View/IncreaseGridSize/Key=#"
"$$$/AgLibrary/Menu/View/ZoomIn/Key=Cmd+#"
"$$$/AgLibrary/Menu/View/ZoomInMinor/Key=Cmd+Option+#"
"$$$/ImportView/Shortcut/ZoomIn=#"

"$$$/AgDevelopShortcuts/Create_Virtual_Copy/Key=Befehl + '"
(changed to "Befehl + T")


I agree with you that these localizations should be provided by Adobe, but for right now this is the way to go. But it's very cumbersome to do all the changes (over and over with new releases ....).

Beat
Photo of rambalac

rambalac

  • 6 Posts
  • 1 Reply Like
Doesnot help if you have several languages
Photo of peter burger

peter burger

  • 5 Posts
  • 0 Reply Likes
Yes this not work for other languages, idiot lightroom developers
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4427 Posts
  • 1637 Reply Likes
Or the easier way is this plug-in: http://www.photographers-toolbox.com/...
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 38 Reply Likes
I have KeyboardTamer licensed and installed, but I just don't use it because I'm not happy with it. A few reasons:

  • Under Win7, you have to modify access rights to make it work

  • Some shortcuts cannot be modified at all (like zoom-in on secondary monitor)

  • Some I just cannot get working :-(



Beat
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4427 Posts
  • 1637 Reply Likes
Have you reported those issues to Tim? He may be able to fix it.
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 38 Reply Likes
No, I haven't, I just got too frustrated with it. And I found the editing of the file to be an OK workaround.

... and I know I should have ......
Photo of Michelle Brügger

Michelle Brügger

  • 3 Posts
  • 0 Reply Likes
Thnx for your tips! I'll give it a try with your workaround Beat ;)

Does it change the information within the menues for the shortcouts as well or do I have to replace them virtually in my head with the ones I put in that file? *smile*
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 36 Reply Likes
It also changes the shortcuts displayed in the menues and the shortcut help.
Photo of Michelle Brügger

Michelle Brügger

  • 3 Posts
  • 0 Reply Likes
Would be gread though if I wouldn't have to do that in all Adobe-Programs I use. If it has to be changed within the settings or a txt-file doesn't matter to me - what bothers me is that I HAVE to do this at all. These aren't freeware-/sharewareprograms where I would live with it - these are pricey programs I paid for 8/
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 36 Reply Likes
I agree with you. Also, I wouldn't know how to change the shortcuts in other Adobe programs.

Beat
Photo of rambalac

rambalac

  • 6 Posts
  • 1 Reply Like
Keyboard shortcuts are not working in non-English keyboard layout.
I have English(default) and Russian keybord layouts, in Russian layout all shortcuts except numbers stop working

English Lightroom 4.1 [829322]
Windows 7 SP1 English

This reply was created from a merged topic originally titled
Shortcuts are not working.
Photo of LRuserXY

LRuserXY

  • 426 Posts
  • 41 Reply Likes
When LR is set to german, the keyboard shortcut for destination gamut warning while in softproof mode is Shift+S. However, Shift+S is already used by "before only", and that seems to take precedence. So it is not possible to toggle the destination gamut warning by keyboard in german.

The same seems to be the case for french and swedish (judging from the resource files).

This reply was created from a merged topic originally titled
Lightroom 4: German: Keyboard shortcut conflict for softproof destination gamut warning.
Photo of LRuserXY

LRuserXY

  • 426 Posts
  • 41 Reply Likes
Note: For german, this has been fixed. The "before only" mode is now accessible through Shift+v and there is no longer a conflict.
Photo of Claire DESCAMPS

Claire DESCAMPS

  • 1 Post
  • 0 Reply Likes
How to toggle showing/hiding the filter bar with a keyboard shortcut when using an azerty Belgian keyboard with LR4.1RC2 US version ? "\", "$" doesn't work. Same problems with other non alpha characters ! [, ], ...

This reply was created from a merged topic originally titled
Using foreign keyboard with Lightroom 4.1.
Photo of Martin Hopf

Martin Hopf

  • 20 Posts
  • 13 Reply Likes
There are a lot of shortcuts within LR which is very good. But still there are some circumstances, where they will be rendered completely usless as of different keyboard layouts in different countries.
Example: German version of LR: The shortcuts for zooming in and out are the + and # keys. So far so good. There are a number of countries which also use german langugage, such as switzerland. The point is, swiss keyboards have quite a different layout from german ones - and quite some of these keys are only to acheive with shift or AltGr modifiers. And that's the problem - it doesn't work. So there are whole countries out there which are not able to use the keyboard shortcuts. I guess there are more countries which are problematic, not just switzerland. As I understand, within Lightroom there is Language = Keyboard of main country the language is used.
Or am I missing something?

This reply was created from a merged topic originally titled
Keyboard shortcuts: no way to use them for e.g. Swiss Keyboards.


Note: This topic was created from a reply on the Lightroom: Language selector and Keyboard shortcuts topic.

This reply was created from a merged topic originally titled
LIGHTROM: Keyboard shortcuts: no way to use them for e.g. Swiss Keyboards.
Photo of Chris Searle

Chris Searle

  • 4 Posts
  • 0 Reply Likes
This is something I've been struggling with since I started with LR two versions back.

The brush size keyboard shortcuts [] on the norwegian keyboard layout (mac) are opt-8 and opt-9, which LR ignores. Same for before after - \ is Cmd-Shift-7.

I've also tried using them on the wacom express keys - don't work there either.

Only way to use them via the keyboard in LR 4 is to switch keyboard layout to an english one (both directly and via the wacom keys).

This has been driving me nuts.

In PS CS6 I can go in and edit the shortcuts - but LR appears to be fixed.

How can I either change the shortcuts or make them work?

This reply was created from a merged topic originally titled
Lightroom - keyboard shortcuts on non-english keyboard.
Photo of Chris Searle

Chris Searle

  • 4 Posts
  • 0 Reply Likes
Hmm - my thread got merged in here - problem now is - norwegian isn't one of the languages that there is a TranslatedStrings.txt for - I kind of guess I could copy one of the others. Shame that the english directory only contains a license file. Not sure what to copy now. I still want the rest of the interface in english :(
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4265 Posts
  • 1547 Reply Likes
Create a blank TranslatedStrings.txt file and just copy the lines that you want changed from one of the other languages. The rest of the interface will stay in English.
Photo of Chris Searle

Chris Searle

  • 4 Posts
  • 0 Reply Likes
Ah. Sounds interesting. Will give it a go
Photo of JOSE L URENA

JOSE L URENA

  • 20 Posts
  • 2 Reply Likes
The solution should be that Adobe develops a Keyboard Shortcut Re-Mapper function for Lightroom, just like the one Photoshop has. This problem is very annoying and it never gets fixed by Adobe, version after version.
Photo of peter burger

peter burger

  • 5 Posts
  • 0 Reply Likes
yes, shit app developing
Photo of Arnold Bartel

Arnold Bartel

  • 186 Posts
  • 42 Reply Likes
This reply was created from a merged topic originally titled Lightroom: LR5: some shortkeys troublesome on non-english keyboard layouts.

Using the spot removal/healing brush I frequently need to use the '/' key to select new source. (also because of this issue http://feedback.photoshop.com/photosh... ).

Using a german layouted keyboard where the '/' is accessed via 'shift'+'7' this doesn't work. The use of the 'shoft lock' key + '7' works as a workaround but interferes and makes troubles with other shortkeys.

So there should be a shortkey concept for all language and keyboard layout options.