Did the Lightroom Classic CC Upgrade Destroy My Catalog? Really??!!!!

  • 1
  • Problem
  • Updated 12 months ago
I have two catalogs.  One was so full with pictures (the "Lightroom" catalog) it became so intolerably slow to exit and backup that I created a new catalogue as I got a new camera (the "Hasselblad" catalog).

The Hasselblad library updated fine into Lightroom Classic CC, but when I tried to update the other older catalog (which I had been using about every other week for old pictures, so I know it worked fine), the great majority of my pictures didn't appear.  I figured it was some error I didn't have time to figure out for several weeks, but today I've tried to tackle the problem.

Looking at my catalog file directory (see copy attached), I've been through and tried to load up each of the catalogs appearing there.  Each time I do so, it creates a new catalog based on the data existing in the older catalog.  Anyway, I can't seem to find my many years of edits (many months or maybe a year of desktop edits.

What the heck is going on?  I see here other people have had similar problems, but there are no solutions in the searches I did anyway.  The files are OK on my hard drive, but my edits appear to have been lost.

I have an old backup from about 6 months ago I suppose I could pull out, but first I thought I'd check here to see if there's any ideas.  For example, is there a backup catalog that I could load up in some other directory?
Photo of Brad

Brad

  • 1 Post
  • 0 Reply Likes

Posted 12 months ago

  • 1

Be the first to post a reply!