Photoshop CC 2015: Design Space preview screen problems

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)

This happened after using Design Space for only a few minutes on a Mac Pro 2008, OS X 10.10.5.

All I had done is turn on a layer that had been turned off.
Photo of Bill Snebold

Bill Snebold

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Ian Wehrman

Ian Wehrman, Employee

  • 5 Posts
  • 4 Reply Likes
Hi Bill,
Sorry about the trouble! Is this a problem that you can reproduce reliably? We haven't seen anything like this before, so we'd really like to figure out what's going on. If you think you can reproduce it, would you be willing to help us by flipping a few developer settings (with instructions) to help us narrow down the problem?

-- Ian
Photo of Jesper Bache

Jesper Bache, Employee

  • 14 Posts
  • 11 Reply Likes
Hi Bill,
I wonder if this is related to an older GPU/driver on your system.
If possible, then maybe you can launch Designspace with GPU (for UI) turned off. (GPU on canvas is still enabled).

To do this, do the following:
Copy the following to a text file and call it settings.json. Don't include "=====" in the file.
The file should start with { and end with }
Put this file inside a folder called "Spaces" inside your external plug-ins folder:
"debuggingPort": 9234,
"enableDeveloperContextMenu": false,
"cef_command_line_arguments": ["disable-gpu", "disable-gpu-compositing"],
"allow_open_gl_canvas": true,
"serialize_use_legacy_keywords": false,
"serialize_use_legacy_encoding": false