custom camera profile missing for selected photos after reimport

  • 1
  • Problem
  • Updated 9 months ago
  • (Edited)
I have a custom profile for my phones RAW files. It is available in all 3 Lightroom versions (mobile for Android, Lightroom Cloud on Windows Desktop and Lightroom Classic on Windows)

Normally it works fine, its even automatically assigned to imported DNGs from the phone.

No I was on a trip and uploaded all my photos (from 3 different cameras + the phone itself) into the phone daily, also did a lot of the editing already.

After the trip I downloaded the whole album (original files + settings) and got them into Lightroom Classic (easiest workflow with Loupedeck and that I'm just used working with it). I deleted the photos on the cloud.

Then after I was done I reimported them back into Lightroom Cloud via the Windows app. Worked good so far too, all the settings from the DNGs and even the XMP files for NEF and CR2 got recognized correctly.

Only thing that doesn't work on the phone is that I now get the "profile missing" warning on the DNGs taken with the phone. BUT: the profile is still there for all the other DNGs I took with the phone that are still stored in the cloud and for new photos taken with it, but on the reimported ones its not shown in the profile selection menu (all the others still show it listed).

While on Lightroom Cloud for Windows desktop the profile is shown in the profile selection menu on the reimported photos, and I don't get the warning there, just on mobile devices.

So whats going on, why is the profile hidden from the reimported DNG files on Android Lightroom?

Edit: Lightroom Web also states the profile as missing on the reimported photos, but available with the older or newer ones.


Photo of Donna Wetter

Donna Wetter

  • 105 Posts
  • 10 Reply Likes

Posted 9 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7541 Posts
  • 1729 Reply Likes
A question about your workflow:

"After the trip I downloaded the whole album (original files + settings) and got them into Lightroom Classic (easiest workflow with Loupedeck and that I'm just used working with it). I deleted the photos on the cloud."

Is there a reason why you just don't allow them to sync into Lightroom Classic?  I am wondering - if you did if your profile would have remained available?
Photo of Donna Wetter

Donna Wetter

  • 105 Posts
  • 10 Reply Likes
Simply because I didn't know about this function. Maybe I should check that out.

It would need the ability to very clearly setup what to sync and what not.
(Edited)
Photo of Donna Wetter

Donna Wetter

  • 105 Posts
  • 10 Reply Likes
Also strange, LR CC Desktop says the sync isn't done yet, but there is nothing really happening, no noticeable upload, all the photos are there, have this since a few days. Maybe there is a a bug where it tries to upload the profiles but fails somehow.
Photo of Donna Wetter

Donna Wetter

  • 105 Posts
  • 10 Reply Likes
Ok I think its working now, even though I set to album to "store locally",  if I open one of the photos it still tells me that its downloading the original file (even though  its supposed to be there all ready), after its done with that the missing profile is there.

Still odd behavior and having to do this manually on every devices would be annoying.
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7541 Posts
  • 1729 Reply Likes
That leads me to believe that you still had items syncing and the profile sync was stuck behind other things (as likely was your Store Locally option)
Photo of Donna Wetter

Donna Wetter

  • 105 Posts
  • 10 Reply Likes
Well the desktop app is still in its endless syncing process. It says 1 photo since multiple days.

Edit: ok fixed the pending sync, just finally deleted some of the deleted photos and it was fine.

What is remaining is that the mobile and web client can't access the profile, only after it downloads the original dng the profile appears, with smart preview I always get the "profile missing" message, and the "story locally" switch doesn't help with getting the profile either. But theoretically it should be available any way.

After all the profile is there for other files to use, why should it be linked to every single of the reimported DNGs, its the same profile that has been in use for a while and works fine in the other albums.
(Edited)