Photoshop: CTRL+J no longer duplicates a layer. Setting CTRL+J as keyboard shortcut also doesn't work.

  • 14
  • Problem
  • Updated 1 month ago
  • (Edited)
Up until recently, in Photoshop CC, I could use CTRL+J to duplicate a layer I had selected in the Layers panel. Now, CTRL+J does not do anything when pressed.

I tried going to Keyboard Shortcuts and setting CTRL+J as the shortcut for Layers > Duplicate Layer - and it does not add my shortcut. I can set it to most anything else, such as, SHIFT+CTRL+J - but CTRL+J isn't allowed to be added as a keyboard shortcut for anything and it doesn't even provide a warning about it conflicting with another shortcut, it just doesn't do anything when trying to add CTRL+J as a shortcut to a menu item.

CTRL+J is a widely used shortcut that seems to have been taken away in recent version of Photoshop CC 2017 with no way to add it back manually.

Please add this back as the default or allow users to add it manually.
Photo of stemlund

stemlund

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 14
Photo of Frank Visler

Frank Visler

  • 2 Posts
  • 4 Reply Likes
I have some problem alike this. When i open a photo via lightroom, I cant duplicate the layers in photoshop cc, not using ctrl - j or the menus (all is greyed out).

If i open the image via camera raw in PS , all is ok.

Windows (10 home)  and photoshop is both installed yesterday...

Photo of Hongs

Hongs

  • 5 Posts
  • 1 Reply Like
Danny, Thanks for your words. ... however, it worked when I reset it but now next day I open file from LR to Photoshop it doesn't work, again. Ugh.... don't know why...
Photo of Evelien Reuse

Evelien Reuse

  • 4 Posts
  • 1 Reply Like
@Hongs: the 'solution' is to start Photoshop first and then open the file from LR. That way the shortcuts keep working.

I reached out to Adobe and complained about the issue and also referred to this topic. They only replied I should upvote the issue so the developers would prioritize the issue in the next update.. ugh -_-"

Edit: so everyone who has this problem, please click on "mee too" on top of this page!
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15365 Posts
  • 2239 Reply Likes
Different issue with current release

Please reference the new conversation here: Commands disabled in Photoshop
Photo of Veronica Contino

Veronica Contino

  • 3 Posts
  • 2 Reply Likes
THis Worked for me^^ Ope PS First, then use LR to Edit In PS   Thanks
Photo of Jeff Eppinette

Jeff Eppinette

  • 1 Post
  • 0 Reply Likes
Thanks, Evelien Reuse, starting PS first worked. All my menu options are no longer grayed out.