Photoshop: CTRL+J no longer duplicates a layer. Setting CTRL+J as keyboard shortcut also doesn't work.

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
Up until recently, in Photoshop CC, I could use CTRL+J to duplicate a layer I had selected in the Layers panel. Now, CTRL+J does not do anything when pressed.

I tried going to Keyboard Shortcuts and setting CTRL+J as the shortcut for Layers > Duplicate Layer - and it does not add my shortcut. I can set it to most anything else, such as, SHIFT+CTRL+J - but CTRL+J isn't allowed to be added as a keyboard shortcut for anything and it doesn't even provide a warning about it conflicting with another shortcut, it just doesn't do anything when trying to add CTRL+J as a shortcut to a menu item.

CTRL+J is a widely used shortcut that seems to have been taken away in recent version of Photoshop CC 2017 with no way to add it back manually.

Please add this back as the default or allow users to add it manually.
Photo of stemlund

stemlund

  • 5 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of David Fabian

David Fabian

  • 76 Posts
  • 18 Reply Likes
When I read this, I thought Whaaaaaat?  So I tried it.   The same thing happened to me, Select a layer, press Ctrl+J and Nothing.   I was holding the left Ctrl.
I Switch to the right Ctrl+J and it worked first time.  Great!
Exit PS Save Nothing.

Go back into PS, load new PSD file.   Left Ctrl +J now works.  Some Preference file probably needed to be woken up.
Photo of eartho

eartho

  • 749 Posts
  • 184 Reply Likes
ctrl-j has not been taken away... something is messed up in your Ps prefs or windows.
Photo of John Maguire

John Maguire

  • 397 Posts
  • 82 Reply Likes
I'D reset your preference file, sounds like it may have ben corrupted.
Photo of stemlund

stemlund

  • 5 Posts
  • 0 Reply Likes
I tried the right CTRL key and that produced no results. I also tried resetting my preferences and restarting Photoshop with no results. This issue is still not resolved for me.
Photo of John Maguire

John Maguire

  • 397 Posts
  • 82 Reply Likes
did you look under keyboard shortcuts and menu. By default it should read Set: Photoshop defaults. As you see below mine reads Steven (modified). For some reason, resetting preferences doesn't effect that. Also when I installed PS 1701.1.1 half of my tools were missing.



Photo of stemlund

stemlund

  • 5 Posts
  • 0 Reply Likes
I don't have any extra keyboard shortcut 'sets'. Only the 'Photoshop Defaults', which doe show 'CTRL+J' as the command for Layer > Layer via Copy.

I just now discovered that if I press CTRL+ALT+J, it does actually work to copy the layer. Now I need to figure out why ALT is required to make this shortcut work.
(Edited)
Photo of stemlund

stemlund

  • 5 Posts
  • 0 Reply Likes
I just now discovered when I try to change a keyboard shortcut and try using CTRL+ALT+J, a warning appears tells me that 'The ALT key is used for "New layer via copy with new layer dialog". Assigning Alt to Layer > New > Shape Layer Via Copy will remove this functionality. 

I'm confused because I can't find where "New layer via copy with new layer dialog" is in my keyboard shortcuts window and how I can change that shortcut. Also what is the difference between "Shape Layer Via Copy" and "New layer via copy with new layer dialog". 

"New Layer Via Copy" seems to be replaced with "Shape Layer Via Copy" when you begin modifying Photoshop Defaults. 

UGH!!!!
Photo of John Maguire

John Maguire

  • 397 Posts
  • 82 Reply Likes
When you modify any keyboard shortcut it automatically save the defaults and creates a new set. so I would change it to what the default CTRL-J should be and see if it works for you and save it. Or wait until a tech catches on to your problem and gives an alternate fix.

Just a thought but what workspace are you in. essentials, photography or something else. Maybe whatever workspace your in other than the first two maybe the reason ctrl j is different.
(Edited)