Photoshop: CS5 won't print to 11"x17"

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
CS5 (Windows 7) can't change setting to print on 11"x17" paper. Adjusting the page settings for the printer seems to have no effect on the Print dialog
Photo of Micha Salomon

Micha Salomon

  • 3 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14651 Posts
  • 1949 Reply Likes
Are you running Windows 7 64bit? What printer are you using? Do you have the latest drivers for your printer? Do you have all the Photoshop updates? http://adobe.ly/PS-Up-To-Date
Photo of Micha Salomon

Micha Salomon

  • 3 Posts
  • 0 Reply Likes
using 64 bit
printer: Xerox WorkCentre 7665 rev 2.0 PS (multiple paper tray), connected thru G-bit Ethernet
Just installed the adobe updates, but problem persists.

Printing works fine from CS4, when I make the page size settings in the Page setup dialog
Photo of Dave Polaschek

Dave Polaschek, Employee

  • 8 Posts
  • 2 Reply Likes
You'll need to change the paper size somewhere in the "Print Settings" dialog. It's in there somewhere, but different printers have the paper size hidden in different places, so it may take some searching.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14651 Posts
  • 1949 Reply Likes
You access Print Settings by clicking this button in the Print dialog:



There, you have access to select Paper Size, Paper Handling and Paper Feed, etc:

Photo of Micha Salomon

Micha Salomon

  • 3 Posts
  • 0 Reply Likes
That's what I've been trying to do, but no matter how many times I change this to 11x17:

But it never registers in the Print Dialog, I keep getting this (note page size is still 8.5x11):

Luckily I still have CS4 installed so I can work around this, but it should work in CS5. Thoughts?
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 116 Reply Likes
Do you have the latest version of the driver installed? It was just released a couple days ago.
Photo of Lune Axelsen

Lune Axelsen

  • 2 Posts
  • 1 Reply Like
After much toil and struggle with this same issue, I have discovered the answer to changing the print size in the xerox dialogue box! You must click the arrow next to the paper type box in the xerox menu and select "advanced paper selection." Under "Paper Size" select tabloid. Seems if you don't specify here, photoshop doesn't read the paper size.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 814 Reply Likes
Photoshop only gets the paper size from the printer driver -- if the driver is not recognizing the paper size, then the driver won't tell Photoshop about it.
Photo of Lune Axelsen

Lune Axelsen

  • 2 Posts
  • 1 Reply Like
It's kinda weird on xerox's part cuz you have to specify the paper size in 2 places. It took me a while to find advanced paper settings and I was just about ready to throw in the towel. Funny thing is I don't have to go through this same process to print from illustrator to the xerox printer.
Photo of Christian Kennel

Christian Kennel

  • 1 Post
  • 0 Reply Likes
I am having the same issue on a Xerox 7845 Workgroup Printer but I don't have an "Advanced Paper Selection" option in my Xerox Dialog box. I have looked everywhere and even when I specify Tabloid it still prints and preview letter. I was able to export to a PDF and then print form there but it is a workaround that is slow and cumbersome. I should be able to print tabloid from Photoshop CS6 with not issues. Seems like a Xerox Printer Driver Issue. Mine works fine in Illustrator too.

Strange.
Photo of chad spencer

chad spencer

  • 1 Post
  • 0 Reply Likes
I found a way for it to work use this driver

PS Driver, Xerox User Interface (Rev 1.0)

I found it on the Xerox website under 7675/7665 win vista x64

It seems to be working when I choose a paper size it now changes like it should without having to go through all of those steps.
Photo of LP81

LP81

  • 1 Post
  • 0 Reply Likes
Choose "Print Options"
Under the Paper Selection, click the arrow on the right side
Choose "Other Size"
Specify the Size in the "Output Paper size" AND the "Original Document Size" inputs.

This will now print to the correctly sized paper as well as show the correct dimensions in the Print Preview