CS6 when "Save as" file name is used....

  • 1
  • Problem
  • Updated 5 years ago
  • Not a Problem
In Photoshop CS6 if I have a .dng file open on my CS6 screen or whatever type of file and I do a "Save as" to change it to a ".jpg file" the file name listed at the top of the workup screen does not change to ".jpg" It remains .dng. I need to close the .dng file and then open the .jpg file. Didn't have this problem with previous versions of Photoshop. I am using a Mac.
Photo of Michael Dean

Michael Dean

  • 11 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
I assume you mean the filename in the top of the document window/tab ?

That's because you had to save a copy -- you didn't save in a format that could include all the data in your document.
And I'll bet it's because your document is 16 bit/channel (which JPEG can't handle).
Photo of Michael Dean

Michael Dean

  • 11 Posts
  • 0 Reply Likes
Yes at the top of the document tab. No the photos are 8 bit. I do the same thing in CS5 and it works without any problem.
Photo of Michael Dean

Michael Dean

  • 11 Posts
  • 0 Reply Likes
Anyone with Adobe Tech know how to correct the above problem?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Unless I check the "as a copy" checkbox when saving, I can't reproduce this.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
So you are doing something that is forcing it to save as a copy - and the fact that the filename doesn't change is completely expected.
Photo of Michael Dean

Michael Dean

  • 11 Posts
  • 0 Reply Likes
What is the something I am doing? I'm changing a file from .dng or .psd to .jpg using "Save as". You said earlier you checked the "AS A COPY" please explain how you were able to to that. Is it something that's setup in preferences? Yours must not be grayed out. Mine is.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
I opened a DNG as 8 bit/channel RGB, and "as a copy" was available and not forced.
If you opened as 16 bit/channel, then it would be forced and the checkbox grayed out when you save as JPEG.
Photo of Michael Dean

Michael Dean

  • 11 Posts
  • 0 Reply Likes
As I have stated previously, I am using 8 bit not 16 bit.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Well, you have something that forces the document to always save as a copy, and what you describe is the expected behavior when you save as a copy.
Photo of Michael Dean

Michael Dean

  • 11 Posts
  • 0 Reply Likes
Also after trying to save to .jpg, in the folder where the file is located the "KIND OF IMAGE" is blank with 2 hash marks instead of JPEG IMAGE.
Photo of Pete Green

Pete Green, Customer Advocate

  • 699 Posts
  • 126 Reply Likes
Did you copy plugins over from CS5?
Sounds like you might have a duplicate FileFormats plugin loaded.

Try turning off the "additional plugins folder" if you have set that up, or remove the plugins that you may have copied over, if that is indeed the case.
Photo of Michael Dean

Michael Dean

  • 11 Posts
  • 0 Reply Likes
Thanks but no. I did have earlier. I have deactivated, uninstalled and reinstalled CS6 for the 3rd time now. The only plugin I have in CS5 is Lucisart. I do have the latest Nik software and I checked with them on compatibility with CS6. However before I added the NIK software plugins I attempted the "Save as" with the same results listed earlier. Once I use the "Save as" and go to the folder and view the file, "kind of image" is blank or with 2 hash marks. I have found out now that if I click on a file listed above it in the folder and go back to the .jpg file that I saved previously, the "kind of file" will then display JPEG IMAGE. Kinda strange but that's what I am doing now. Also Pete, If I try to edit a photo in LR4 it works fine with the edit box "What to Edit" if I want to edit with CS5, but I don't get that if I want to edit with CS6.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
The "kind of image" is because your OS hasn't parsed the file for metadata yet. That's unrelated to the "save a copy" issue you started with.
Photo of Michael Dean

Michael Dean

  • 11 Posts
  • 0 Reply Likes
Yes unrelated!
Photo of eLearnerGSU

eLearnerGSU

  • 1 Post
  • 0 Reply Likes
All you have to do is flatten the image. The message and the warning will go away and the file will be saved.

(I can't take any credit for this; I just read it in a different after spending about ten minutes trying to figure what the *&/% everybody was talking about in this forum).

Remember Occam's razor.