Photoshop CS6 and earlier: Compatible with MacOS Sierra 10.12?

  • 9
  • Question
  • Updated 2 months ago
  • Answered
  • (Edited)
CS5 Photoshop incompatible with MacOS Sierra? Should have read the warnings before I upgraded. Does this mean I can never use Photoshop again? (the end of the world) or will an Adobe fix occur in the future?
Photo of Guerry


  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 9
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13635 Posts
  • 1546 Reply Likes
Official Response
Older versions like CS5 can run on Sierra if you install the legacy Java Runtime from here:

For instructions on installing older versions of Creative Suite on Sierra:

Printing currently does not work on Sierra for some printers: A workaround is being investigated.