PHOTOSHOP CS3: Adobe updater not working. Can't register CS3

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
I installed CS3 on my new mac and prompted that I needed to download 2015-001 to get legacy Java. I did the download and now I get a message that Adobe updater will not work and I cannot register CS3.
Photo of Terry Meyers

Terry Meyers

  • 5 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 2

Be the first to post a reply!