Elements 13: Crop tool degrades performance

  • 4
  • Problem
  • Updated 4 years ago
  • (Edited)
In PSE 13, the crop tool has been change in a way that seriously degrades performance under certain conditions (specifically, whenever the crop tool is selected!)

If the crop tool is active, then after each and every action (add layer, change blend mode, etc) the crop suggestion thumbnails are regenerated, and even on a fast machine that results in a very noticeable delay.

Obviously, this can be avoided by remembering to always deselect the crop tool after selecting it, but I often forget, and get very annoyed by (again) having to wait. You can find a copy of threads about this very bothersome behavior on the Elements Village.

The consensus seems to be to simply provide a switch to turn off the crop suggestions feature.
Photo of Tom Gettys

Tom Gettys

  • 17 Posts
  • 1 Reply Like

Posted 4 years ago

  • 4
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
What OS/version are you on? Is your graphics card driver up to date?
Photo of Tom Gettys

Tom Gettys

  • 17 Posts
  • 1 Reply Like
Windows 7 Professional. Since the responders to the thread over at Elements Village all reported seeing the same behavior, I think it safe to assume it is not the fault of the hardware.

Perhaps just try it yourself and I think you will understand the issue; simply select the crop tool and then go over and change the blend mode of some layer. You should observe a delay before the new crop suggestions are redisplayed down in the tool options panel.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14146 Posts
  • 1765 Reply Likes
I'll pass it on the the Elements team to repro.
Photo of Tom Gettys

Tom Gettys

  • 17 Posts
  • 1 Reply Like
Thanks Jeffrey!
Photo of Mike Valiska

Mike Valiska

  • 1 Post
  • 0 Reply Likes
Please give us a method to turn off the crop suggestions.
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1085 Posts
  • 227 Reply Likes
Be sure to uncheck the option in the Edit/preference, General, menu to turn off automatic crop preselection option.
If you don't move your cursor on the options icons in the panel of the crop tool, you'll get no crop suggestion.
(I have upgraded to version 13.1)