Crash on XPS 15 9570 when GPU is enabled

  • 1
  • Problem
  • Updated 1 week ago
  • Solved
Crash on Dell XPS 15 9570 after a few seconds working in PS when GPU is enabled.

This is a dual-GPU system with Intel HD 630 + Nvidia 1050Ti Max Q 

The latest manufacturer drivers have been applied, as well as all updates from Dell and Microsoft.

The OS is Win 10 Pro 1803. Core i7 and 32GB RAM. UHD screen

The crash report always mentions StretchBlt, so I guess it's graphics-related :)

Turning off GPU solves the issue but this makes this $3000 laptop perform like a $500 one.

Same problem with same symptoms in LR classic.

I also tried rollbacks etc...

I am NOT allowed to disable the Intel GPU because it is needed for proper video signal routing, even when app is using discrete GPU.

I am getting kinda desperate and I really do not know what to do. Nvidia optimus seems to be the culprit (or at least the way Adobe is using it)

No other gpu-heavy apps crash.

THANKS a lot for any advice.
Photo of Benjamin Golinvaux

Benjamin Golinvaux

  • 22 Posts
  • 11 Reply Likes
  • desperate

Posted 2 weeks ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4426 Posts
  • 860 Reply Likes
When you say "The latest manufacturer drivers have been applied, as well as all updates from Dell and Microsoft."  Were the video drivers downloaded from Microsoft and Dell? Or, were they downloaded from the nVidia site? Windows drivers for nVidia tend to run a version or two behind. 
Photo of Benjamin Golinvaux

Benjamin Golinvaux

  • 22 Posts
  • 11 Reply Likes
Hello.

I used Dell Update to download the latest drivers. Since the crash still occurred, I install the very latest drivers from Nvidia driver support page (417.01 as of today) and the crash is still the same.

The call stack always mentions StretchBlt. 

What's "funny" is that Lightroom Classic also crashes very quickly when GPU is enabled, but crashes too after 10 or 15 minutes when GPU is disabled, also with a crash dump mentioning StretchBlt (when assigned, in Windows, to the Nvidia GPU). I still haven't tried running everything with GPU disabled AND assigned to integrated graphics.

What a pity.... Being unable to take advantage from such a powerful machine.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4426 Posts
  • 860 Reply Likes
A clean install of your nVidia software may be in order. You would need to uninstall all nVidia drivers, restart and then install the latest build. 

Let me know how it goes. 
Photo of Tadas Černiauskas

Tadas Černiauskas

  • 1 Post
  • 0 Reply Likes
I have the same laptop and the same issue. Uninstalled all nvidia software/rivers, restarted and loaded photoshop which started using Intel UHD Graphics 630 graphics card and for 5 minutes of doing various tasks photoshop seems to be stable. 

But as it was mentioned before "this makes this $3000 laptop perform like a $500 one"
Photo of Benjamin Golinvaux

Benjamin Golinvaux

  • 22 Posts
  • 11 Reply Likes

Hello

I fixed my issue :) 


Even though the active GPU was Nvidia, the fix was to upgrade the INTEL drivers. I know this sounds strange.


I was @ version 24.xxx   and I had to upgrade to 25.xxx


However this is not straightforward : if you just download the new driver and launch exe, in my case, it refused to install because manufacturer drivers were installed (Dell). I had to :


- Download latest Intel driver from  Downloads for Intel® HD Graphics 630  (in my case, since I have HD 630)

- Unzip the exe in a folder using, for instance, 7zip

- go to device manager (Windows + X --> device manager)

- uninstall Intel drivers and click on "Delete driver files"

- DISCONNECT YOUR INTERNET CONNECTION

- In the device manager, right-click anywhere and choose "Scan for hardware changes"

- Wait for the Intel display adapter to appear

- Right click and choose "Update driver". If it is disabled, click on Properties then Driver then Update driver.

- Choose "Have disk" and locate the place where you extracted the Intel driver

- Let it install


Hopefully once this is done, your problems are over. They were for me, even though I was using the Nvidia driver!!!! (go figure)


A reboot might be necessary.


Wish you all the best of luck