Photoshop CC 14.2.1: Could Not Complete Your Request Because of a Program Error

  • 3
  • Problem
  • Updated 4 years ago
  • (Edited)
I downloaded Photoshop CC about a week ago and have been receiving the following message whenever I try to use certain tools or features:

"Could not use the (tool) because of a program error."

I've updated to version 14.2.1 and tried clearing the font cache without success.

These are the tools affected:
- Eye dropper tool
- Rectangle tool
- Rounded rectangle tool
- Ellipse tool
- Polygon tool
- Line tool
- Custom shape tool

Also, when I swap/change the foreground and background colors I receive the same message. However the colors do change.

Any Ideas?
Photo of DKP

DKP

  • 1 Post
  • 0 Reply Likes
  • Frustrated

Posted 5 years ago

  • 3
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
What OS version?
Have you tried clearing/resetting Photoshop's preferences?
Photo of Caitlin Bauer

Caitlin Bauer

  • 2 Posts
  • 0 Reply Likes
Having the same issue. Most current version of Photoshop CC and Mac OSX.
Photo of Kenneth Quade

Kenneth Quade

  • 3 Posts
  • 0 Reply Likes
Same issue on Windows 8.1 Photoshop CC. Anyone fix it? I hit "d" for the default fore/background and get the error. Shapes will not show up either.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14551 Posts
  • 1893 Reply Likes
Is Photoshop is Up-To-Date? http://adobe.ly/PS-Up-To-Date

If it's up to date, try restoring your preferences: http://blogs.adobe.com/crawlspace/201...

If you do restore your prefs, please save a copy of your existing prefs in case they turn out to be the culprit. Having the bad prefs can sometimes help us track down the issue.
Photo of Kenneth Quade

Kenneth Quade

  • 3 Posts
  • 0 Reply Likes
It's up to date, yes.

I wish I had read his first. I deleted my prefs, and it did the trick!

This all started few days ago. I saved a file. I created a new one, put down a custom shape, and it was invisible to me. So I hit "d" to eventually make it black, and I got the error.