Photoshop: Could not complete your request because of a program error.

  • 20
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)
i keep getting this message when i try to do anything in photoshop a second time what i mean is when first opened photoshop works when i close the first image the go to do anything else i get the message: Could not complete your request because of a program error.i have uninstalled and reinstalled photoshop cc but no difference i have taken a couple of screen shots which i hope will give you more information

i hope you can solve this problem as i am at my wits end
Photo of Mike Stapleton

Mike Stapleton

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 20
Photo of Jan L

Jan L

  • 7 Posts
  • 0 Reply Likes
Amy, Follow Jefferey's advice above. This worked for me.

Photo of Amy Griffin

Amy Griffin

  • 3 Posts
  • 0 Reply Likes
thank you Jan L. I can't seem to find the users/tranber(?)/Library/Application Suport/Adobe. Can you advise me on how to get to this folder?

Thanks much!
Photo of Amy Griffin

Amy Griffin

  • 3 Posts
  • 0 Reply Likes
I found the path! Let's see if it works.

Thank you.
Photo of Jan L

Jan L

  • 7 Posts
  • 0 Reply Likes
Fantastic. Let us know if it works out.
Photo of Brian Biddle

Brian Biddle

  • 17 Posts
  • 0 Reply Likes
So..... still having the same issues....no resolution here.
Photo of Brian Biddle

Brian Biddle

  • 17 Posts
  • 0 Reply Likes
Just tried with "application frame" not selected and was able to open a few more files before the error message appeared.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15409 Posts
  • 2260 Reply Likes
Even with the new user account that was created?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15777 Posts
  • 2417 Reply Likes
Does the problem go away if you change the Finder view to Icons, List or Coverflow?

http://feedback.photoshop.com/photosh...
Photo of Brian Biddle

Brian Biddle

  • 17 Posts
  • 0 Reply Likes
No, does not go away.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15777 Posts
  • 2417 Reply Likes
Earlier in the thread you said the issue went away for you with a new Admin user account. Are you still using that new Admin user account and having the problem again?
Photo of brianbiddle

brianbiddle

  • 14 Posts
  • 2 Reply Likes
On a completely new setup with same problem. (new macbook, new PS install, new user profile)
Photo of corey gibbons

corey gibbons

  • 1 Post
  • 0 Reply Likes
I'm having the same problem as well. I go to open a 3rd or fourth file and it says the sam error. I save and restart PH and same thing happens.
Thanks
Photo of rohan verma

rohan verma

  • 1 Post
  • 0 Reply Likes
to resolve this problem to Edit / Preferences / Type and change the Type Engine from East Asian to Middle Eastern and restart Photoshop. it worked for me
Photo of Rocky Davies

Rocky Davies

  • 2 Posts
  • 0 Reply Likes
Hi all, I'm another one with this same problem. I tried various suggestions in this thread, but to no avail.

Here is my strange circumstance though. If I am in Photoshop CC and try to hit command + O as I commonly do to open an additional file, I get the error. However, if I go to a Finder window and double click the file, it will open. I've tried it several times, back and forth.

I can open from Finder, but not Photoshop. So at this point its just an annoyance, but regardless, I would like it to work either way as intended.

I don't know if my little addition helps narrow the problem or not.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Are you on MacOS 10.10? The open/save dialogs have a few problems on 10.10, the worst of which was fixed in 10.10.1, but there are still some odd errors happening that Apple is still trying to fix.
Photo of Rocky Davies

Rocky Davies

  • 2 Posts
  • 0 Reply Likes
I am using 10.10.1. Hopefully they will get it fixed soon, it'd be nice for it to work properly.
Photo of brianbiddle

brianbiddle

  • 14 Posts
  • 2 Reply Likes
I've not posted to this issue in over 20 days...hoping a new macbook and fresh user profile would resolve this issue for me.

I'm on a new install of CC2014, New user profile and yet I'm still having the same issue. I can open files on 1st launch. Then after two or three files have opened I get the old: "Could not complete your request because of a program error."
Photo of brianbiddle

brianbiddle

  • 14 Posts
  • 2 Reply Likes
Also seeing the same error message when I try to load new swatches.
Photo of brianbiddle

brianbiddle

  • 14 Posts
  • 2 Reply Likes
Removed the swatches palette and reopened photoshop. Was able to open a handful of PSD files 20 or so...but eventually the same error message reappeared.
Photo of brianbiddle

brianbiddle

  • 14 Posts
  • 2 Reply Likes


Screenshot showing an error that has shown up in Photoshop using the keyboard shortcut to open files (cmmd + o)

This is on a brand new macbook pro, fresh install of Photoshop CC14, and new user profile.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
That is a completely different issue, caused by an OS bug in MacOS 10.10.
Photo of brianbiddle

brianbiddle

  • 14 Posts
  • 2 Reply Likes
Ha! - So, I've done two things that seems to have fixed the issue for me.

1. Finder is now set to list (was on columns)
2. Removed USB overdrive (3rd party plugin)

So far so good.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15446 Posts
  • 2282 Reply Likes
Thanks Brian, if you go back to Column now that you've removed "USB Overdrive" do you still get the error?
Photo of brianbiddle

brianbiddle

  • 14 Posts
  • 2 Reply Likes
Funny enough - I've added USB Overdrive back while still in list view for the finder and no problems so far.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15446 Posts
  • 2282 Reply Likes
The best test would be whether column view works without "USB Overdrive" installed. That way we could tell whether USB Overdrive is the root of the problem or if it's the OS by itself.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15777 Posts
  • 2417 Reply Likes
For the other folks on this thread, how many of you are using "USB Overdrive"?
Photo of Michael Ashby

Michael Ashby

  • 11 Posts
  • 1 Reply Like
not me.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15777 Posts
  • 2417 Reply Likes
But it sounded like your issue was caused by user permissions. When you created the new user account it worked correctly, no?
Photo of Michael Ashby

Michael Ashby

  • 11 Posts
  • 1 Reply Like
I could not get it to work in my profile... Another user profile is of not much use... I do not have info how to resolve permissions on my own profile... I tried all the advice and no luck...so I now use older version of PS... A small nuisance and not ideal, but workable
Photo of lineke essed

lineke essed

  • 3 Posts
  • 0 Reply Likes
Is there a solution yet? I'm also getting really frustrated. I've upgraded to Yosemite 10.10.2 and am using Creative Cloud Adobe
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
Please read the existing responses -- every case is different, and we need more information to figure out what exactly is going wrong in your case.
Photo of lineke essed

lineke essed

  • 3 Posts
  • 0 Reply Likes
Well, I've read the responses but understand half of the things said. So how do I get my problem solved. What kind of information do you need?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15409 Posts
  • 2260 Reply Likes
Try creating a new Admin user account and run Photoshop from the new user account to see if the problem goes away: http://blogs.adobe.com/crawlspace/201...
Photo of lineke essed

lineke essed

  • 3 Posts
  • 0 Reply Likes
Well, the problem goes away but now I cannot access any of my files on the other user? So what now? How do I transfer all my files to the new user?
Photo of Michael Ashby

Michael Ashby

  • 11 Posts
  • 1 Reply Like
Ditto...
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15409 Posts
  • 2260 Reply Likes
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15409 Posts
  • 2260 Reply Likes
Prior to trying to correct the user, can you try this log generation for Mac OS X.

Switch back to the bad/affected user account, and then confirm you can reproduce the problem.

Then, to collect sysdiagnose, hit shift-control-option-command-period. The screen will flash and a few minutes later a finder window should open with an archive
Photo of Michael Ashby

Michael Ashby

  • 11 Posts
  • 1 Reply Like
got that...what do we do with this sysdiagnose file? Thanks
Photo of Eric Gaudreau

Eric Gaudreau

  • 2 Posts
  • 0 Reply Likes
Is there a solution to this issue? I'm new to Mac and Photoshop and I've tried most of the sugguestions above that I understand and know how to do.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
Read the previous replies - it is not a single issue. We need more information to know what sort of issue you are encountering.
Photo of Eric Gaudreau

Eric Gaudreau

  • 2 Posts
  • 0 Reply Likes
I get the message when I try to either open another file after editing a jpg or when I trice to Place Embedded. I haven't done any updates or added any apps to my Mac and Photoshop was working fine until the last week or so.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
That sounds like you might be hitting one of the known MacOS 10.10 bugs -- which we have documented for Apple, and Apple is working on solutions for.
Photo of s

s

  • 11 Posts
  • 0 Reply Likes
Same problem here. It usual follows after i switch application and come back, which i when the brush tool won't work either...
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
Which version of Photoshop are you using?
Which OS version are you using?
What does the PSErrorLog.txt file say?
Photo of s

s

  • 11 Posts
  • 0 Reply Likes
Latest version of photoshop CC, updated as soon as update was available hoping it would fix problem.

Mac os X yosemite on two macs, One iMac late 2012 and one macbook pro mid 2012

I have the same problems on BOTH computers.

PS error log here: http://adobe.ly/1MyA0Xl
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
You are using Photoshop CC (14.2) not the latest version Photoshop CC 2014 (15.2).

And the log says you have a problem with your color profiles or color settings directory - if it happens at launch, then it would be the color settings directory; if it happens when switching apps, then the colorsync profiles or cache are more likely.
Photo of Cindy Boyd

Cindy Boyd

  • 1 Post
  • 0 Reply Likes
same problem here. new imac and new yosemite up to date with CC fresh install. worked fine for a week. now errors trying to open.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
MacOS 10.10 has well known problems in the OS open and save dialogs that can cause program errors. Some people have avoided the problems by changing the view in the OS dialogs, others have not been so lucky.
Apple is aware of these issues in MacOS 10.10 and working on solutions.
Photo of ElenaMoc

ElenaMoc

  • 1 Post
  • 0 Reply Likes
The solution is as simple as frustrating in the problem. All you have to do is to reset Photoshop CS6’s Preferences File - I have CS6, if you have other version reset that one. And also, following exactly the same steps, reset Camera Raw settings. To learn how to reset Photpshop preference file watch this great video with Julianne Kost: http://tv.adobe.com/watch/the-complet...

Don't forget to do exactly the same steps with Camera Raw.
Let me know if it worked for you.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Program Errors have many different causes, and resetting the prefs may fix a few, but not all of them.
Photo of Fahim Jabbar

Fahim Jabbar

  • 7 Posts
  • 0 Reply Likes
Hello. I'm getting the same error message "your request could not be completed because of a program error". And unlike most guys here I'm running PS on Windows 7 Ultimate laptop.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
That is a generic "we don't know what went wrong" message. You'll have to provide a lot more information to figure out what is causing it on your system.
Photo of Fahim Jabbar

Fahim Jabbar

  • 7 Posts
  • 0 Reply Likes
OK what info do you need?

I'm using PS CS6 Extended, and I'm receiving this error for: color dropper tool, the sliders in replace color, draw figure (line, polygon etc). Opening and saving the documents is working fine for me, and its been only a few days since I'm receiving the error.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
The PSErrorLog.txt contents would help.
Have you tried resetting Photoshop's preferences?
Photo of Fahim Jabbar

Fahim Jabbar

  • 7 Posts
  • 0 Reply Likes
Yes I did reset the preferences, but its still same. Can you please tell me where can I find PSErroeLog.txt on my PC?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
That file is in your Photoshop preferences folder.
Photo of Fahim Jabbar

Fahim Jabbar

  • 7 Posts
  • 0 Reply Likes
2015:04:26 23:51:56 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:52:00 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:52:23 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:52:26 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:53:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:53:37 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:53:49 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:54:09 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:54:19 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:26 23:54:31 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 00:11:27 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 00:11:33 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 00:12:43 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 00:14:50 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 02:47:43 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 02:48:59 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:04:27 02:57:41 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:05 00:22:00 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:05 00:22:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:11:27 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:11:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:11:49 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:11:55 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:25:25 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:25:33 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:25:36 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 02:29:31 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 03:28:39 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 03:28:46 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 03:34:04 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:07 03:34:09 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:30 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:41 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:48 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:01:53 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:02:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:02:21 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:04:02 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:04:09 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:04:11 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:04:14 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:25:47 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:25:51 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:25:53 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:25:58 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:30:56 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:31:02 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:34:03 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:39:13 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 02:39:24 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:12:37 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:13:09 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:13:20 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:13:25 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:15:06 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:28:45 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:29:01 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:33:18 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:33:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:34:16 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:45:20 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:45:22 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:45:26 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:48:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 03:49:39 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:42 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:45 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:48 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:51 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:18:53 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:01 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:04 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:07 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:11 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:15 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:18 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:28 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:45 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:47 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:50 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:19:58 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:20:01 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:20:04 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:23:48 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:23:54 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:23:56 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:06 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:10 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:16 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:18 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:29 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:24:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:25:28 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:25:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:25:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:26:28 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:26:32 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:26:34 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:37 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:41 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:43 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:49 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:51 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:56 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:29:58 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:03 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:05 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:36 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:41 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:30:43 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:32:03 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:32:06 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:32:08 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 22:58:53 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 23:03:37 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 23:09:08 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:08 23:47:35 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 00:46:03 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 03:13:00 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 03:13:05 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 03:47:17 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
2015:05:09 04:04:59 : ..\..\sources\USheet.cpp : 454 : REQUIRE failed
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Something in your document is trying to pass a bad color mode to a layer function that expects a valid mode for layers. My guess would be shape layer tools, but resetting prefs should clear that.
Photo of Fahim Jabbar

Fahim Jabbar

  • 7 Posts
  • 0 Reply Likes
But I already tried that. I clicked on the "default" button wherever it appeared in preferences and it notified me that the changes will take place on next PS launch. So I closed PS and restarted it but still the same.

Is there any other way to reset preferences?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
That doesn't sound like you reset preferences at all. There is no such button to reset preferences in the shipping version of Photoshop.

Either hold down control-alt-shift while launching Photoshop and say "yes" to deleting the prefs, or just delete the files in the Photoshop preferences folder.
Photo of Fahim Jabbar

Fahim Jabbar

  • 7 Posts
  • 0 Reply Likes
No there's no "reset" button, but is a "default" button in a few categories within preferences. But I didn't know it doesn't reset it, never have faced any issue before so no experience with technicalities. Thanks for info, I'll try it.
Photo of Fahim Jabbar

Fahim Jabbar

  • 7 Posts
  • 0 Reply Likes
OK I tried the method you told, and the preferences are reset. Saying that, the issue is solved. Thanks for the assistance.
Photo of Megan Wessels

Megan Wessels

  • 3 Posts
  • 0 Reply Likes
I'm having the same problem. Have tried deleting the preference files from the Library, disabling third party plug-ins and deselecting 'Enable generator'. Nothing works. This is the error log I get:

2015:03:13 16:47:36 : /Volumes/workarea/PS_15_Mac_Daily_Retail/20141204.r.310/photoshop/main/photoshop/sources/USheetList.cpp : 246 : REQUIRE failed
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
That error should be cleared with resetting preferences -- it means that something is holding onto some layer data with a color mode that is not valid for layers.
Photo of Megan Wessels

Megan Wessels

  • 3 Posts
  • 0 Reply Likes
Thanks for your reply Chris. I thought that in order to reset preferences you had to delete the preference files. Is this not correct? If not, how does one reset?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Deleting the preferences files works, or holding down control-alt-shift (command-option-shift on Mac) at launch.

It is also possible that some extension panel or third party plugin could be causing the bad reference somehow.
Photo of Megan Wessels

Megan Wessels

  • 3 Posts
  • 0 Reply Likes
It's still not working... anything else I can try?
Photo of Ian Sears

Ian Sears

  • 2 Posts
  • 0 Reply Likes
PS error prompt: "Could not complete your request because of a program error." (OK button)
Desktop Mac Pro running OS X Version 10.7.5
PhotoShop vCS4 v11.0
Lightroom v4

VERY likely Culprit ---> Fonts and PhotoShop

Possible root cause in my case:

LightRoom hang began this maybe??
My instance of this issue only began happening maybe 1 month ago. I think I am correct that it only began happening after my install of Adobe LightRoom v4 hung my machine during an Import of jpegs. This curiously ALSO hung the Finder. While able to Force Quit Lightroom v4 at that time I was curiously UNABLE to ReLaunch Finder. Full freeze. Hard Power off. Hard power up. I'm pretty certain that power up was when I first began to notice this error with PhotoShop then starting up for the first time following that LRv4 freeze.

CONDITIONS of occurrence:
Only happens when PS4 is started up.
AND in that instance ONLY happens IF a document is opened.
AND in that instance ONLY happens IF the document has had the Type Tool clicked (or text actually added to the document) and then saved.

IF I open PhotoShop CS4 with no document, error does not present itself.
If I create a new, Untitled document, leave and return to PS4, the error does not present itself.
IF I quit PS4 with that new (now saved as) document left open, relaunch PS4 with that document auto-opening, the error does not present itself.
IF I click the Type tool, the error instantly presents itself.
IF I quit PS4 without saving that document, relaunch PS4 with that document auto-opening, the error does not present itself.
IF I quit PS4 after adding a letter and saving the document, relaunch PS4 with that document auto-opening, the error instantly presents itself.

My instance of this issue happens (only) when I first fire up PhotoShop CS4 and open a document that has some sort of text in it.

The error produces a variable number of repeated prompt(s) each saying the same error. However the variable is 7 (OR) 8 recurrences. I dismiss each with (OK).

Once I have:
- Fired up PhotoShop CS4 (WITH A DOCUMENT)
- Left the application (clicked on an open browser window for example)

At that time, PhotoShop produces the first instance of this error.
I switch to PhotoShop again, dismiss the 7 instances of the error (sometimes 8 instances of the error) and it does not occur again for the rest of the day.

If I quit PhotoShop, and then launch PhotosShop, THEN the above repeats itself.

I ALSO have PhotoShop CS5 installed (have had both versions installed for years now without conflicts or issues....). PhotoShop CS5 DOES NOT exhibit any of these issues.

No resolution on my part yet. I have long since forgot how to chase down Font issues in OS X (I've not added any or modified any in months and months... years?).

Does this spark any ideas to chase down? Anything I can provide to assist resolution?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
First, install the updates for Photoshop CS4. You should be on 11.0.2.

Start here for troubleshooting fonts and OS font caches: https://helpx.adobe.com/photoshop/kb/...
Photo of Ian Sears

Ian Sears

  • 2 Posts
  • 0 Reply Likes
Thanks for your suggestions Chris.
I'll update this after I've completed your suggestions.
Photo of Erick Robinson

Erick Robinson

  • 1 Post
  • 0 Reply Likes
I just downloaded OSX 10.11 (El Capitan) last week. I am using Photoshop Elements 11. When I try to open a .pdf file I get the message "Could not complete your request because of program error". It seems that many of the comments above were for different versions of either OSX or Photoshop.

Thanks in advance for your help.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15365 Posts
  • 2239 Reply Likes
Sounds like a permissions issue. Try creating a new Admin user account and run Photoshop from the new user account to see if the problem goes away: http://blogs.adobe.com/crawlspace/201...
Photo of Михаил Косулин

Михаил Косулин

  • 2 Posts
  • 0 Reply Likes
WTF
same error on gradient tool and saving:



2016:02:12 01:40:35 : tracked key 0000000000008018 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 0000000000007F78 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 0000000000007F70 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 00000000000065C8 of type struct _ARef * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 00000000000001E0 of type struct _ALst * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 0000000000007F68 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 00000000000065C0 of type struct _ARef * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 00000000000002E8 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 0000000000000248 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 0000000000000240 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 0000000000000088 of type struct _ARef * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:35 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:35 : tracked key 0000000000000030 of type struct _ALst * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:36 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:36 : tracked key 0000000000000238 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:36 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:36 : tracked key 0000000000000080 of type struct _ARef * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:36 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:36 : tracked key 000000000000ED18 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:36 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:36 : tracked key 000000000000B418 of type struct _ARef * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:36 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:40:36 : tracked key 000000000000ED10 of type struct _ADsc * __ptr64 not found : 1 : REQUIRE failed
2016:02:12 01:40:36 : e:\ps15\ps_16_win_x64_daily_retail\20160113.r.355\photoshop\main\photoshop\interfaces\UTrackResourceImp.h : 137 : REQUIRE failed
2016:02:12 01:41:50 : ..\..\sources\USheet.cpp : 461 : REQUIRE failed
2016:02:12 01:41:54 : ..\..\sources\USheet.cpp : 461 : REQUIRE failed
2016:02:12 01:44:13 : ..\..\sources\USheet.cpp : 461 : REQUIRE failed
2016:02:12 01:44:16 : ..\..\sources\USheet.cpp : 461 : REQUIRE failed
2016:02:12 01:49:08 : ..\..\sources\USheet.cpp : 461 : REQUIRE failed
2016:02:12 01:49:10 : ..\..\sources\USheet.cpp : 461 : REQUIRE failed
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
Most of those are from an automation plugin or extension panel.
The last set from USheet are probably the program error you're seeing. Unfortunately, it doesn't really tell us where the error came from, just where it happened.

Please create a copy of your Photoshop preferences folder, then reset your Photoshop preferences. If that solves the issue, then zip the prefs folder you copied and email it to me.
(Edited)
Photo of Михаил Косулин

Михаил Косулин

  • 2 Posts
  • 0 Reply Likes
Reseting all preerences solves this issue. Before this I tried to reinstall, but settings syncs from Adobe CC
Photo of KaraKoles El Puro

KaraKoles El Puro

  • 2 Posts
  • 0 Reply Likes
Hello guys! Sorry to bother you but I couldnt find a solution for mine:

2016:04:25 21:55:19 : ..\..\jpeg\JPEGStream.cpp : 176 : REQUIRE failed
2016:04:25 21:55:19 : ..\..\jpeg\JPEGStream.cpp : 195 : REQUIRE failed
2016:04:25 21:55:19 : ..\..\jpeg\JPEGStream.cpp : 176 : REQUIRE failed
2016:04:25 21:55:19 : ..\..\jpeg\JPEGStream.cpp : 195 : REQUIRE failed

Just open jpgs... and it doesnt with every picture just with few of them
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Can you send one of those JPEGs to ccox (at) adobe (dot) com?
Photo of KaraKoles El Puro

KaraKoles El Puro

  • 2 Posts
  • 0 Reply Likes
Done. Thanks a million in advance.
Photo of Neil Gallagher

Neil Gallagher

  • 1 Post
  • 0 Reply Likes
Михаил Косулин, i just wanted to say thank you, it worked thank God :)

"Reseting all preferences solves this issue. Before this I tried to reinstall, but settings syncs from Adobe CC"
(Edited)
Photo of James Stretten

James Stretten

  • 2 Posts
  • 0 Reply Likes
Why the hell aren't bloody Adobe or Apple answering these questions? When did we arrive at a situation where ordinary users are supposed to solve bugs in programmes?!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15446 Posts
  • 2282 Reply Likes
There are several replies from Adobe on this thread. What is your specific problem? Can you provide details about your setup and steps to consistently reproduce your issue?
Photo of James Stretten

James Stretten

  • 2 Posts
  • 0 Reply Likes
System is Mac OS El Capitan 10.11.6
Photoshop CS3

Message 'Could not complete your request because of a program error' appears randomly plus sometimes the programme itself has to be forced to close.

There are no steps that will CONSISTENTLY reproduce the issue as it is entirely random.

My issue is that surely this is something for either Apple or more likely Photoshop THEMSELVES to address - not loads of ordinary users like me.