Photoshop CC 2015: Program error when creating layers from layer style

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Hi,

I get the message, "Could not complete your request because of a program error.", when I attempt to "create layers" from an effect. I was able to do this a few times then the error began showing. I used MacOS first aid and updated to the most recent Photoshop 2015 CC (2015.1.1). There are no plug-ins. The problem remains.
El Capitan 10.11.2 (15C50)
Mac (Retina 5K, 27-inch, Late 2014)
3.5 GHz Intel Core i5
16 GB 1600 MHz DDR3
AMD Radeon R9 M290X 2048 MB

Is there a solution?

Here are the last entries from the PSErrorLog.txt.

2015:06:16 17:03:49 : tracked key 0000000000000200 of type P5_ADsc not found : 1 : REQUIRE failed
2015:06:16 17:03:49 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20150529.r.88/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2015:06:16 17:03:49 : tracked key 0000000000000048 of type P5_ARef not found : 1 : REQUIRE failed
2015:06:16 17:03:49 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20150529.r.88/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2015:06:16 17:03:49 : tracked key 00000000000001F8 of type P5_ADsc not found : 1 : REQUIRE failed
2015:06:16 17:03:49 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20150529.r.88/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2015:06:17 14:34:29 : tracked key 0000000000002350 of type P5_ADsc not found : 1 : REQUIRE failed
2015:06:17 14:34:29 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20150529.r.88/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2015:06:17 14:34:29 : tracked key 00000000000002E0 of type P5_ARef not found : 1 : REQUIRE failed
2015:06:17 14:34:29 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20150529.r.88/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2015:06:17 14:34:29 : tracked key 0000000000002348 of type P5_ADsc not found : 1 : REQUIRE failed
2015:06:17 14:34:29 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20150529.r.88/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2015:06:17 16:59:22 : tracked key 0000000000000110 of type P5_ADsc not found : 1 : REQUIRE failed
2015:06:17 16:59:22 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20150529.r.88/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2015:06:17 16:59:22 : tracked key 0000000000000050 of type P5_ARef not found : 1 : REQUIRE failed
2015:06:17 16:59:22 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20150529.r.88/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2015:06:17 16:59:22 : tracked key 0000000000000108 of type P5_ADsc not found : 1 : REQUIRE failed
2015:06:17 16:59:22 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20150529.r.88/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed

Thank you in advance.
Photo of Lonnie Timmons III

Lonnie Timmons III

  • 5 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Those errors are all due to bugs in automation plugins or extension panels (most likely third party).

But you also haven't installed the 2015.1 or 2015.1.1 updates.
Photo of Lonnie Timmons III

Lonnie Timmons III

  • 5 Posts
  • 0 Reply Likes
How do I solve the problem? How do I disable these plugins or extensions? I'm not sure why you write that I haven't updated when photoshop shows that I have the most current version. Why the discrepancy?


Photo of Lonnie Timmons III

Lonnie Timmons III

  • 5 Posts
  • 0 Reply Likes
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
Is there a particular file or effect that causes this for you? If you have a file, or exact steps to repro, that might help us.
Photo of Lonnie Timmons III

Lonnie Timmons III

  • 5 Posts
  • 0 Reply Likes
I uploaded the wrong end of the PSErrorLog.

2015:12:17 08:23:40 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20151209.r.327/photoshop/main/photoshop/framework/sources/DynamicArray.cpp : 159 : REQUIRE failed
2015:12:18 08:08:07 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20151209.r.327/photoshop/main/photoshop/framework/sources/DynamicArray.cpp : 159 : REQUIRE failed
2015:12:18 08:09:04 : /Volumes/workarea/PS_16_Mac_Daily_Retail/20151209.r.327/photoshop/main/photoshop/framework/sources/DynamicArray.cpp : 159 : REQUIRE failed
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
OK, that looks more like the problem you're describing (and a bug).
Unfortunately that doesn't tell me where the bug is, but gives some clues about what kind of problem to look for.
Photo of Lonnie Timmons III

Lonnie Timmons III

  • 5 Posts
  • 0 Reply Likes
I am trying to create a layer from the Bevel & Emboss effect.