Lightroom: Corrupt Catalog

  • 1
  • Problem
  • Updated 7 years ago
  • Solved
  • (Edited)
I have Lightroom 1.4 and every time I try to open it and run a backup it says the "The Lightroom catalog "Lightroom Catalog" is corrupt and cannot be used or backed up until it is repaired."

I run the repair, it says it is successful, but when I try to open and backup again, I get the same error.

I upgraded to Lion. COuld that be the problem?

thanks
Bridgitte
Photo of Bridgitte Krupke

Bridgitte Krupke

  • 4 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2656 Posts
  • 341 Reply Likes
Can you open it w/o backing it up? If so what happens?
Photo of Bridgitte Krupke

Bridgitte Krupke

  • 4 Posts
  • 0 Reply Likes
I can, and everything initially looks fine until I tried to import new photos. It says it's importing, then says those files already exist, although I cannot find them.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2656 Posts
  • 341 Reply Likes
I don’t remember your old version well enough to know if this is an option, but if it is, try creating a new catalog (which is an option), and then import from the old catalog using File / Import Catalog (which I’m not sure is an option) that isn’t quite working, and see how much come across.
Photo of jdv

jdv, Champion

  • 728 Posts
  • 56 Reply Likes
Also, use the demo version of the latest release to upgrade a COPY of this catalogue. This might indicate if it is a 1.4-on-Lion issue.
Photo of Bridgitte Krupke

Bridgitte Krupke

  • 4 Posts
  • 0 Reply Likes
I downloaded a demo of the latest version, and upgraded a copy of the catalogue, but when it opened, none of my previous files are there, it does successfully import the new files I couldn't open earlier though. ugh!
Photo of TK

TK

  • 531 Posts
  • 111 Reply Likes
Not sure if LR 1.4 supports this, but try to export all your images in the old catalog as a new catalog.

Then try to open that exported catalog.

P.S.: How big is your catalog? Would it be feasible to scroll through all images in the grid mode (Select "All Photographs") and check for any which are not represented by a thumbnail, i.e., just leave a grey box? If you find these, deselect them before you export the rest using "Export as Catalog". Your new catalog should be clean then.
Photo of TK

TK

  • 531 Posts
  • 111 Reply Likes
BTW, not being able to find images that are reported to be in the catalog already can point to catalog corruption, but it also may just mean that the images are hidden in a stack. Are you using stacks? If so, unfold them first before you are searching for images.
Photo of Bridgitte Krupke

Bridgitte Krupke

  • 4 Posts
  • 0 Reply Likes
HOORAH! I exported a copy of all the images in the old catalog as a new one and re opened in the latest version and everything seems to be working. Thanks TK and everyone for your help!

Bridgitte
Photo of TK

TK

  • 531 Posts
  • 111 Reply Likes
Glad it worked for you!