Lightroom Mobile correct colors don't load unless in edit module

  • 1
  • Problem
  • Updated 5 days ago
  • In Progress
  • (Edited)
Correct colors don't load in Lightroom Mobile for my Android unless in Edit module. Photos load in "Info" and "Rate & Review" dull. When I switch to edit module the loading circle appears and the colors will load correctly. Comparing to my capibrated computer monitor (and my desired look of the photo) I can confirm this). If I swipe to a new image and back the same thing will happen. Load dull at first then properly.

Switching back to "Info" or "Rate & Review" after letting the colors load in the Edit module will keep the correct colors until I switch images. No matter what module I am in when changing images it will initially load with the wrong colors (then the correct ones if in Edit).

When I load on a tablet it will open with the wrong colors first then load the correct ones. Tablets are always in Edit so I can't say if the same thing is happening other than swiping from one image and then back it has to reload the colors. Again this is comparing them with my monitor, phone and my desired look.

If I "Save To Device" or "Share With" another app it comes out as the dull image. This really makes the Lightroom Mobile app useless as it is not exporting the image I developed and the only way I can use this to share/display is to be in the edit mode. Not ideal.

The rest of my edits appear just the colors are wrong. Even having the collection downloaded to the device doesn't make a difference.
Photo of Matt Dillon

Matt Dillon

  • 7 Posts
  • 2 Reply Likes
  • Very annoyed.

Posted 2 weeks ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3924 Posts
  • 1352 Reply Likes
To start trying to narrow this down, can you confirm which camera profile is being used on the photo please? And what kind of edits are applied?

Oh, and which Android device?
(Edited)
Photo of Matt Dillon

Matt Dillon

  • 7 Posts
  • 2 Reply Likes
Hi and thanks for the reply.

LG G6 (Main device)
Nexus 6 (Tested this issue on)
LG G Pad X 8 (tablet)

Photos taken with either Nikon D750, D5100 or LG G6.

ALL photos give me this issue on all devices. They only display correctly if loaded in Edit view. They safe/share dull and lifeless with the colors looking wrong. Not just some but every one that I have edited. Every photo type including RAW (NEF), dng, tif, PSD and JPG.

Profiles: Adobe Color, Color, Vintage 09.

Edits include most Basic Panel adjustments other than Dehase.
Some have minimal Tone Curve (Point Curve, RGB) adjustments.
Sharpening and noise reduction reduction.
Some have Remove Chromatic Aberration.
Some have mild Vignette.

This is a screenshot with an edited photo showing the exported copy on left with Lightroom Mobile on the right. The colors are all wrong.


This screenshot shows an image with no edits. The exported version is on the left with Lightroom on the right. Again the colors are wrong.
Photo of Matt Dillon

Matt Dillon

  • 7 Posts
  • 2 Reply Likes
Photos "Save To Device" or "Share To" like above no matter if I let them load in the Edit module or not. If I don't switch to the Edit module then the photo will stay looking like the exported version (left side) in Lightroom Mobile. Once I switch to Edit the proper colors load. That goes for edited/non edited photos as shown in the screenshots of my previous post.
Photo of Matt Dillon

Matt Dillon

  • 7 Posts
  • 2 Reply Likes
Also, OPENING up a photo from Lightroom Collections Creative Cloud through Photoshop Mix (same devices) loads the images with the wrong colors. Same if I were to share with an app like Snapseed. They all look just like they do before the colors load in Lightroom's Edit module. Again the colors match my calibrated monitors a lot more after they load in the Edit module.



Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3223 Posts
  • 547 Reply Likes
Matt,

I've asked one of the Lightroom CC for Android to take a look and give us some additional information. Stand by please!
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3223 Posts
  • 547 Reply Likes
Thanks for the great info and screenshots Matt.

With your help we were able to identify a couple of scenarios where the color space for the preview and the edit areas could be different. We've logged a bug for it and hope to have it to you in an upcoming version. 
Photo of Matt Dillon

Matt Dillon

  • 7 Posts
  • 2 Reply Likes
Awesome! Thank you.