Lightroom Classic: Copying metadata from videos in no longer working since last update

  • 2
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)
In the past it was possible to easily copy metadata from video files in lightroom classic to an edited copy of the video by using the built-in "Copy metadata..." and "Paste metadata.." functions. Since last patch of Lightroom Classic this does not work anymore. All fields in the copy dialog are empty even if the source video has metadata. However, the copy process still works with pictures. Only video files seem to be affected by the bug.
Photo of Marco Seelig

Marco Seelig

  • 2 Posts
  • 1 Reply Like
  • frustrated

Posted 8 months ago

  • 2
Photo of Forrest Brown

Forrest Brown

  • 2 Posts
  • 0 Reply Likes
I've noticed the same thing. It's worked before, but the last couple of updates this hasn't worked. I've made sure that everything is check on the copy window the comes up when you select Copy Metadata, but when I paste, nothing is pasted and it erases anything that was already there. It also does not work if you use Sync MetaData.

It seems to work with photos, it's only videos that copy/sync metadata is not working.

Lightroom Classic version: 8.4.1 [ 201909111355-eb9b68f0 ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.14.6 [18G95]
Application architecture: x64
Logical processor count: 16
Processor speed: 3.6 GHz
Built-in memory: 65,536.0 MB
Real memory available to Lightroom: 65,536.0 MB
Real memory used by Lightroom: 10,918.8 MB (16.6%)
Virtual memory used by Lightroom: 77,611.9 MB
Memory cache size: 4,409.4MB
Internal Camera Raw version: 11.4.1 [ 291 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 161MB / 32767MB (0%)
Camera Raw real memory: 161MB / 65536MB (0%)
Displays: 1) 5120x2880

Photo of Sumeet Choudhury

Sumeet Choudhury, Employee

  • 57 Posts
  • 21 Reply Likes

Thanks for reporting the issue. A bug is logged for the same. We will work on it.

Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7294 Posts
  • 1658 Reply Likes
Lightroom Classic 9.0 was released earlier today and contained a fix for this issue. Please give it a try and confirm it is working for you after updating. Thanks for your patience.
Photo of Marco Seelig

Marco Seelig

  • 2 Posts
  • 1 Reply Like

The update to Lightroom Classic 9.0 seemed to have solved the problem. Copying metadata from video files works again.

Thanks !
Photo of Forrest Brown

Forrest Brown

  • 1 Post
  • 0 Reply Likes
Seems to be working fine for me also.