Photoshop: F5 shortcut for action, deletes layer (fixed in 14.1.2)

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
I used to have an action recorded for the menu item "Convert to Smart Object" but since the latest Photoshop update the action now deletes the layer.

I tried re-recording the action but it still does the same thing.

Choosing the menu item "Convert to Smart Object" works fine - it is only when it's recorded as an action that it is deleting the layer.
Photo of Edward Bloor

Edward Bloor

  • 7 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1224 Posts
  • 172 Reply Likes
I can’t reproduce the issue.
Care to let us know which exact version of Photoshop you are using?
Photo of PECourtejoie

PECourtejoie, Champion

  • 792 Posts
  • 285 Reply Likes
Hello, yes, we need more information: is it a pixel layer, a vector one, a smart object that you try to convert into another one?
Photo of Edward Bloor

Edward Bloor

  • 7 Posts
  • 0 Reply Likes
It occurs when I want to turn a bitmap (pixel) image into a Smart Object.

If I paste vector artwork from Illustrator into Photoshop as a Smart Object, that works fine.

It is only when I turn it into a command, attached to F5 that it happens.

I'm using Photoshop CC 14.1.1 on a Mac running OSX 10.8.4.

Actually I've just found this other post, which seems to indicate that it is the key F5 which is at the root of the problem:

http://helpx.adobe.com/photoshop/kb/l...
Photo of Edward Bloor

Edward Bloor

  • 7 Posts
  • 0 Reply Likes
Yes, if I change it to another function key it works ok.

I'd be interested to know if anyone else gets layers deleted using F5 in Photoshop, if you have an action attached to that key.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
That's a known problem, discussed elsewhere. The F5 key command gets converted to delete by mistake. We're working on a fix.
Photo of PECourtejoie

PECourtejoie, Champion

  • 792 Posts
  • 285 Reply Likes
Hello, this is fixed in the last 14.1.2 update released today: http://blogs.adobe.com/crawlspace/201...