Contract selection -bug in Elements 11

  • 2
  • Problem
  • Updated 5 years ago
I have a small but annoying bug in Photoshop Elements v. 11.0. I often want to add a border around my images, say 1px black, to give it a frame. With past versions of Photoshop, I've used 1) ctrl-A (select all) 2) Select-->Modify-->Contract (contract by custom px) 3) ctrl-shift-I (select inverse) 4) Edit-->Fill. It's easy! But when I try to do this in Elements 11, the Modify-->Contract option is grayed out and cannot be selected after ctrl-A. It works for ALL other selections that are smaller than the whole image, but it should work for ctrl-A as it has in all other Photoshops before it. I would also be grateful for any nifty work-around tips.
Photo of lauri kauppila

lauri kauppila

  • 2 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1129 Posts
  • 235 Reply Likes
The usual way to do this is:
- to select all (Ctrl A)
- use the menu Edit / stroke

and choose 'inside' and the the pixel width.
Photo of lauri kauppila

lauri kauppila

  • 2 Posts
  • 0 Reply Likes
Thanks Michel, that works great.

Furthermore, if I select my new "stroke" border with the magic wand tool, I get a selection area exactly equivalent to what I originally wanted. I can use this selection area to edit other layers for more extravagant border effects (not just solid color). So... this work-around gives me back everything I need.
Photo of Suzanne Tourtillott

Suzanne Tourtillott

  • 2 Posts
  • 0 Reply Likes
Haha there's even a bug in the "Add Image" feature on this site!

In this PSE 9 Adobe TV demo, Select > Modify > Contract is an option. http://tv.adobe.com/watch/learn-photo....

It doesn't work in my brand-new PSE12 (not an upgrade from an earlier version). Here's a screenshot...if it will work...screen froze after upload.
Photo of Suzanne Tourtillott

Suzanne Tourtillott

  • 2 Posts
  • 0 Reply Likes