Photoshop: Constant problems with Generator

  • 3
  • Problem
  • Updated 2 years ago
  • (Edited)
Anyone else experience constant problems with Generator?

I get this almost every time I try to use it. I don't even have any other extensions installed.

Try reinstalling Photoshop? Seriously???!?
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes

Posted 2 years ago

  • 3
Photo of Max Johnson

Max Johnson, Champion

  • 432 Posts
  • 198 Reply Likes
It would be nice if there were a way to clear out all of the hidden saved generator data. I don't know where it's saved in the document but sometimes the only way to fix it is to literally make a new document and copy layers one at a time then recreate the layer groups from scratch.
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
It would be nice if Generator worked more than 25% of the time
(Edited)
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
What's funny is I often get the error above just before Generator actually STARTS working!
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1734 Reply Likes
Do you have the Extension for Edge Reflow installed? There was another thread where this extension was messing with Generator?
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
I don't know what that is...how can I check?
Photo of John

John

  • 1 Post
  • 0 Reply Likes
I also have this problem since upgrading to Photoshop v17.0.0
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
This is killing me!! Generator still never works consistently. Sometimes I spend 30 minutes trying everything to get my layers to start generating. Please fix this!!!