All software: PPC/10.4-10.5 Compatibility increases sales

  • 1
  • Idea
  • Updated 7 years ago
  • Not Planned
  • (Edited)
Like me a lot of Mac users have G5 power Pc 2.7 Ghz ,very good machines that it is stupid to put them in the trash.Do you want to increase your sales?make software also compatible with operative system 10.4 and 10.5.
Photo of Rui Cunha

Rui Cunha

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Official Response
Sorry, it is very expensive to create and test software for multiple architectures. Apple is no longer supporting PPC architecture itself (Apple OS 10.6x "Snow Leopard" cannot be installed on PPC software and OS 10.7 no longer supports Rosetta PPC emulation). The last PPC hardware rolled off the production line over five years ago (Aug. 2006). Unfortunately, we can't support platforms that the original manufacturer isn't supporting moving forward.

FWIW -The Intel processors absolutely kill PPC chips in performance. I had a the last top-of-the-line PPC PowerMac tower and the very first Intel iMac (prototype) that came out was twice as fast to launch and run most applications. I just bought a new iMac for at home and love it.