Compatibility OS X El Capitan version 10.11.6 -Lightroom Classic

  • 1
  • Question
  • Updated 4 months ago
I had to download OS X El Capitan version 10.11.6 on my MacBook Pro. I'd like to know if it's compatible with Lightroom Classic which I'd like to subscribe to. Thank you
Photo of Thomas

Thomas

  • 1 Post
  • 0 Reply Likes

Posted 4 months ago

  • 1

Be the first to post a reply!