Photoshop: Colour shifts when switching to fullscreen mode (CS5, Mac 10.7)

  • Problem
  • Updated 11 months ago
  • Solved
  • (Edited)
Hi there,
My problem began a few days ago when I exported some photos from Lightroom and began opening them in Photoshop. I'm working on a Macbook pro so I use an external NEC monitor for most editing. So now when I have an image open in Photoshop and I hit the 'f' key to got to full screen mode, the colour suddenly goes all wrong (like a wrong colour profile). It appears to be a display problem as I can save changes to an image where the colour has been messed up, and when I reopen it the colours are correct again. The problem persists with an open image no matter what I do once it has happened until I close the image. So pressing 'f' again until I get back to the regular window doesn't correct it. I use fullscreen mode a lot so this is very frustrating. And the wrong colour issue has begun to happen intermittently in Bridge too when dragging from the laptop screen to the external screen too now. I haven't been able to make it happen with any web browsers or other programs like Preview which display images.

Tech specs:
Mac OSX 10.7.3
Macbook Pro 15" model 6,2 core i7 2 core
8GB RAM
Lightroom 3.6
Photoshop 12.0.4
external monitor NEC 2690WUXi2 with spectraview II calibration
all latest os and photoshop updates were installed before problem began, and subsequent updates have not resolved it.

Photo of Joseph Nicht

Joseph Nicht

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 9
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2150 Posts
  • 206 Reply Likes
Does the Mac version of PS have an OpenGL on/off option like Windows does?
Photo of jdv

jdv, Champion

  • 728 Posts
  • 55 Reply Likes
Sounds like a bad monitor profile.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Chief Customer Advocate

  • 10356 Posts
  • 684 Reply Likes
That was my guess, too. I would try and recreate the profile or try and different one to see if the problem persists.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19453 Posts
  • 540 Reply Likes
Could also be a problem with the GL shader responsible for color correction in GL mode.
Photo of Joseph Nicht

Joseph Nicht

  • 2 Posts
  • 0 Reply Likes
It isn't the monitor profile. I tried recalibrating to no avail. Open GL sounds more like the culprit. From memory i think it first happened when I opened a file after installing the OSX update prior to the current one.
Photo of Rikard Öhlin

Rikard Öhlin

  • 2 Posts
  • 0 Reply Likes
I have this same problem, it started to appear this afternoon.

MacBookPro 8,2, Core i7, 2 GHz, 4 cores, 8GB RAM

Disabling OpenGL does fix it, but i really shouldn't have to do that with this setup.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19324 Posts
  • 515 Reply Likes
Hmm, so it is the GL shader failing. The real test would be: does it happen on MacOS 10.6.8 on the same hardware (10.7 introduced a *lot* of GL driver bugs, not all of which have been fixed yet).
Photo of Tim Lookingbill

Tim Lookingbill

  • 15 Posts
  • 2 Reply Likes
Chris, is there a tech doc I could read about OpenGL and Mac OS 10.6.8, outlining at what point OpenGL is being implemented that affect previews in Bridge's main Preview, Camera Raw 6.6 (all zoomed views) and Photoshop?

Is OpenGL controlling/driving all aspects of preview generation or only intense 3D, filtering and shading?

I'm assuming from your reply OpenGL is aiding color management but not sure to what extent.

Also is Adobe/Mac's preview generation still using any remnants of QuickDraw, QuickTime or (forgot the name) preview generator for postscript integrated within the OS interface.

Is it all now driven by one preview technology?
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19324 Posts
  • 515 Reply Likes
Tim - no, there is no such document. Each app has their own code, and they differ quite a bit.
Photo of Tim Lookingbill

Tim Lookingbill

  • 15 Posts
  • 2 Reply Likes
Thanks, Chris.

One more specific. If I turn off (uncheck) OpenGL Drawing in Photoshop CS5.1 preference does this affect previews in Bridge and Camera Raw 6.6? Or is there another preference adjust separately for these.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19454 Posts
  • 540 Reply Likes
No, it only affects Photoshop.
Photo of Rikard Öhlin

Rikard Öhlin

  • 2 Posts
  • 0 Reply Likes
I don't have this problem at all in Camera Raw (6.6.0.261). Bridge has it, but CR seems to work.
Photo of Rich Meade

Rich Meade

  • 8 Posts
  • 0 Reply Likes
Having the same problem, and it IS a recent development...
working on a Macbook Pro i7...and secondary NEC monitor, that is calibrated regularly....
the files look fine and match my LR window when first opened, but when switched to Full Screen, they go to (well you get the idea)...

Adobe needs to fix this ASAP! It's really screwing up my workflow since I've gotten used to all the fancy zoom and navigation feel that graphics acceleration provides.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19454 Posts
  • 540 Reply Likes
Which OS version?
Which application version?
Photo of Paul Crivellari

Paul Crivellari

  • 1 Post
  • 0 Reply Likes
Having exactly the same problem with a similar configuration. Disabling Open GL is a workaround.

Macbook Pro 8,2
NEC 2960WUXi (secondary display)
OS X 10.7.3
Photoshop 12.0.4

Chris, any additional advice you could offer would be appreciated.
Photo of Robert Whitmore

Robert Whitmore

  • 3 Posts
  • 0 Reply Likes
Hi,

Having the exact same problem too, just started today, was working fine forever until this afternoon.

MacBook Pro 15 inch Early 2011 2.2 Core i7 - 8 GB ram
AMD Raedon HD 6750M 1024MB
OS X 10.7.3
PShop 12.0
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19454 Posts
  • 540 Reply Likes
It should have worked until you installed MacOS 10.7.3.

Apple changed something, and we had to find more ways to work around Apple's issues.

Have you tried CS6? It should work much better.
Photo of Robert Whitmore

Robert Whitmore

  • 3 Posts
  • 0 Reply Likes
Thanks for the feedback Chris. I am beta testing CS6 on my home machine but I am loath to use it on files that will end up back at work (we are a retouching house) for fear of incompatibility.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19454 Posts
  • 540 Reply Likes
Unless you use a document feature new to CS6 - the files are completely compatible. And even if you do use a new feature, the document should be mostly preserved in older versions.
Photo of Robert Whitmore

Robert Whitmore

  • 3 Posts
  • 0 Reply Likes
I understand. I am under strict orders from my IT guy. We have been burned in the past. "Mostly preserved" could easily be an utter disaster for a client.

Will CS5 be updated to work with the latest Lion or is it broke for good?
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19454 Posts
  • 540 Reply Likes
No, we won't be updating CS5 for this issue. Apple broke it, but we doubt that they'll fix it either.
Photo of Carlos Contreras

Carlos Contreras

  • 2 Posts
  • 0 Reply Likes
Hello,

I'm a photographer and I'm just starting with the two monitors (displays) issue, and I'm glad to see that I'm not the only one with this problem.

I'm Using a Macbook Pro i7 Quad 15" and a DellU2410, both calibrated by ColorMunki hadware and ColorEyes Display Pro software. My versin of Photoshop is CS5 (12.0).

I did the Open GL workaround and it seems to solve the problem partially, but I think is really just a workaround that not reflects the real color accuracy you would expect once you spend reasonable time and money to buy and calibrate your hardware.

If you take a look at the Photoshop's Color Settings (Edit > Color Settings), you will see that Photoshop is considering as a MonitorRGB the Macbook Pro profile and not the profile of your display (in my case, the Dell U2410). Attention: you will not select the calibrated profile (select AdobeRGB or ProPhotoRGB), this is just a way to see how Photoshop is managing colors.

Simple test to be done: after be sure that Photoshop is using the MBPro monitor profile, quit photoshop and close you Macbook Pro. If everything works well, your secondary display should turn "MacBlue" and then start to work as a main display, with Dock and Menu Bar. Open Photoshop and check the Color Settings and you will have the MonitorRGB showing the right monitor profile. In this case, you will be able to press F (shortcut to fullscreen) and have no changing of colors, even with OpenGL enabled.

The problem now is how to change the MonitorRGB profile without having to use the secondary display (Dell U2410) profile in your Macbook Pro monitor (the result is very awful).

Can anyone figure out any solution?
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19324 Posts
  • 515 Reply Likes
Photoshop uses each display's profile for color correction of each display.

The "monitor RGB" profile just means the main monitor for convenience.

What you're actually demonstrating is a more complex problem caused by a bug introduced by Apple in an OS update.

Photoshop CS6 has worked around this issue (and some related problems in MacOS).
Photo of Carlos Contreras

Carlos Contreras

  • 2 Posts
  • 0 Reply Likes
Hi Chris, thank you very much for your response. Although the Open GL solution worked out, I miss some features using my Intuos 5, so I'm looking forward to upgrade to CS6.
Photo of Aaron Leimkuehler

Aaron Leimkuehler

  • 6 Posts
  • 0 Reply Likes
I haven't noticed it on my Mac at home, but it just started doing it to me today on my Dell laptop at work. It is with an external monitor also, and I just calibrated it. Very frustrating. Anyone know a quick fix for the same problem on a "pc" running Windows 7?

I never had this problem before today. Not sure what changed, but I don't see where anyone has reported the same problem on anything but a mac. Any advice would be much appreciated. I looked in preferences to find OpenGL to turn it off, but couldn't find anything like that.

Thanks!

Aaron
Photo of mark mui

mark mui

  • 1 Post
  • 0 Reply Likes
I had the same problem, full screen mode showed a color shift in my psd files. Turning off openGL is a work around but I wasn't satisfied with this solution.

I figured out the the problem is a result of your OS (my case, PC) uses a different color profile than photoshop does. When photoshop is in window mode, it uses the OS color profile. When switching into its full screen modes, it then uses the color profile specified in its own color settings.

Solution: on a PC:
1. Start Menu, search: "Color"
2. click Color Management
3. (select your main display if using multiple monitors, make sure you have the correct monitor selected, click "Identify" to be sure and match up the number on your screen with the selection in the Display drop down.)
4. Check "Use my settings for this device
5. click "Add", then scroll down and select sRGB IEC61966-2.1
6. with the above highlighted, click "Set as Default Profile"
7. hit OK, log off and log back on.
8. Fixed

If your working psd files are in a format other than sRGB, I would imagine that you simply have to load that same color profile as your OS profile.

Hope this helps.
Photo of Brandon Tyson

Brandon Tyson

  • 37 Posts
  • 4 Reply Likes
I don't understand why this thread stops here. The above is not a solution. The monitor profile is used to display color to YOU, the local viewer properly. The working space and embedded profile in PS is used to transport and communicate color settings to other people/places/programs. There is a reason these are different. The best example is when I'm working in CMYK. Are you suggesting I load a CMYK monitor profile??? Not possible.

The problem is definitely related to using dual monitors. I have an iMac and Cintiq. I recently created a calibrated profile for the Cintiq, and now Photoshop switches to the wrong profile when exiting full screen mode. I can recover it by moving the layout window onto my iMac and then back onto my Cintiq, and PS will then sense the change and use the correct profile again. I believe this is a Photoshop glitch.
Photo of Brandon Tyson

Brandon Tyson

  • 37 Posts
  • 4 Reply Likes
Awesomely quick response, Chris. Thank you.

I'm on OS X Mountain Lion, fully updated, and PS6, fully updated.

Yes, I am using GPU drawing in Advance mode.
Photo of Aaron Leimkuehler

Aaron Leimkuehler

  • 6 Posts
  • 0 Reply Likes
Hi Chris,

I never received any feedback from an employee to correct the problem on a PC. I agree with Brandon that the above does not work for me as it would require me to lose the calibrated monitor settings in order to accommodate the conflict with Photoshop. I work exclusively in Photoshop adjusting photos for various CMYK press color profiles. I used to work in full screen mode all the time. I can only use it for touch-up work now and then I have to switch back to adjust the color. Sounds like a minor inconvenience to some I suppose, but it's quite frustrating.

My problem is similar to Brandon's, but the color only shifts while in Full Screen Mode. When I leave either of the two full screen modes and return to the floating windows the color has returned to normal.

Do you have any suggestions, or anyone I can contact to help with this problem? My original post was two months ago, and I never heard anything back...?

Thanks
Photo of Brandon Tyson

Brandon Tyson

  • 37 Posts
  • 4 Reply Likes
If your problem is the opposite to mine, I wonder if you are going full screen on your secondary monitor, not your primary?
Photo of Aaron Leimkuehler

Aaron Leimkuehler

  • 6 Posts
  • 0 Reply Likes
I am going to full screen on the secondary monitor. My primary monitor is the laptop. Did they have a solution for you?
Photo of Brandon Tyson

Brandon Tyson

  • 37 Posts
  • 4 Reply Likes
No, no solution. I just thought I'd get you to confirm that so Chris could consider that clue in his notes. It seems that upon exiting full screen mode on the primary monitor, the secondary monitor profile is used. But upon entering full screen on the secondary monitor, the primary monitor profile is used.
Photo of Brandon Tyson

Brandon Tyson

  • 37 Posts
  • 4 Reply Likes
Here are some screenshots that might help. The first one is an example of the same document, duplicated. The one on the right has been into full screen mode and back, and the other never entered full screen mode. You can see the incorrect color in the one on the right.

Again, this is on a setup with iMac and a Cintiq, with a custom color profile on the Cintiq. Adobe Creative Suite Color Settings and North American General Purpose 2, unaltered and synced across CS.









Photo of Brandon Tyson

Brandon Tyson

  • 37 Posts
  • 4 Reply Likes
Another clue, Chris. I remembered that I just recently changed my physical setup to have my iMac on a riser above my Cintiq. So I changed the monitor arrangement in my System Prefs to match. I do not remember seeing the problem before I did that.

On a Mac, that looks like this:
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19324 Posts
  • 515 Reply Likes
The layout shouldn't have any effect, but Apple frequently has bugs with window profiles (yeah, each window has a profile on MacOS) when they release new OS versions.

I suspect that the 10.8 and Windows issues have different causes - but we'll have to continue investigating.
Photo of Debra Maloney

Debra Maloney

  • 1 Post
  • 0 Reply Likes
Yay! I think i've found a work around without having to disable OpenGL.

Cause I like the fancy zoom effects.

Here it is!

Open random file/image press f shortcut to get to full screen view
(yes the colour still shifts), then once in full screen mode open actual file you want to work on and it should open in full screen mode - colour intact. But stay away from that f shortcut, don't change screen mode again. switching from full screen back to window screen also shifts the colour.

I've done a few tests this seems to work.

Now I can get back to work on actual photos.

Hope this helps.
TheDeb
Photo of Stéphane Richard

Stéphane Richard

  • 5 Posts
  • 1 Reply Like
I have the same problem on PC. I'm pretty stuned Adobe didn't come with a fix since CS5. As it's a cross platform problem, and the GPU drivers of either nvidia or AMD had many versions since the first report, it appears to me as a photoshop issue.

As a comic book colorist, switching constantly back and forth between full-screen and windowed modes is a core part of my workflow.

Please Adobe, do something.
Photo of asd dasd

asd dasd

  • 1 Post
  • 0 Reply Likes
The problem was present in cs4, but it could be solved by unchecking the box "color matching" and "advanced drawing" under opengl settings. Since cs5 the checkbox is gone. Please Adobe fix this, it's taking too much time....
Photo of Brandon Tyson

Brandon Tyson

  • 37 Posts
  • 4 Reply Likes
Based on my experience, we'll all have to cause a loud ruckus in order to get attention for this problem. But the thread also needs to be moved to CS6, as it is a current problem.
Photo of Stéphane Richard

Stéphane Richard

  • 5 Posts
  • 1 Reply Like
Ok so, how do we get louder, Adobe? Do you want us to make a facebook page or some kind of online petition to get your attention?
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19324 Posts
  • 515 Reply Likes
Just add your vote at the top. We already heard about the problem. Now we just have to figure out more ways around the bugs in Apple's display code.
Photo of Brandon Tyson

Brandon Tyson

  • 37 Posts
  • 4 Reply Likes
Yes, as Aaron points out below, this is not an Apple-specific problem. I understand that may be the cause on Mac and there could be a separate cause on Windows, but both OS's are experiencing the issue.
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19324 Posts
  • 515 Reply Likes
And we've verified that the causes are different on each platform. We know something about the problems, it just takes time to work around the issues and re-test everything.
Photo of Brandon Tyson

Brandon Tyson

  • 37 Posts
  • 4 Reply Likes
Understood. Thanks, Chris.
Photo of Aaron Leimkuehler

Aaron Leimkuehler

  • 6 Posts
  • 0 Reply Likes
And don't forget to address the problem in PC also. While I appreciate the work-around that Debra Maloney found, it is not remotely feasible in a production workflow. I am in and out of full screen constantly. I do hope they don't only address this problem for the newer versions and completely ignore versions CS4-present.
Photo of Alex York

Alex York

  • 3 Posts
  • 1 Reply Like
A work-around/solution!

It appears that the problem only exists with Basic mode for gpu enhancement. If you switch up to Normal mode or Advanced then the colour shift goes away....

Just an FYI for you all!
Photo of Stéphane Richard

Stéphane Richard

  • 5 Posts
  • 1 Reply Like
This is not a fix for me, the color shift still occur whatever gpu enhancing mode I'm in.
Photo of Bob Yourmom

Bob Yourmom

  • 10 Posts
  • 0 Reply Likes
I switched to "Normal" from basic and now the problem is Fixed. YAY!!! thanks for the tip.
Photo of Jon & Ibe

Jon & Ibe

  • 2 Posts
  • 0 Reply Likes
Had this problem as wel; Alex Yorks solution seems to be the fix.

Win 7 PC - CS6 (master collection) - i7 - NVIDIA GeForce GTX 570
Photo of Aaron Leimkuehler

Aaron Leimkuehler

  • 6 Posts
  • 0 Reply Likes
I'm excited that a solution has been found. However, can someone instruct me on how to make that change. When I go to the settings, I cannot switch it from Basic to anything. The option is not accessible.

Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19324 Posts
  • 515 Reply Likes
Your GPU is not capable of anything beyond the Basic mode, so other functionality is not available to you.
Photo of Aaron Leimkuehler

Aaron Leimkuehler

  • 6 Posts
  • 0 Reply Likes
Thanks for the reply Chris. Is this a problem that is still trying to be corrected, or has this method proven an acceptable "fix" at this time? Are my only options to remedy this to replace the computer or the graphics card?
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 19324 Posts
  • 515 Reply Likes
The color shift on fullscreen is being worked on.

But your only option is to replace or install a better video card (and avoid the Intel GPUs).
Photo of Bob Yourmom

Bob Yourmom

  • 10 Posts
  • 0 Reply Likes
Switching from Basic to Normal Drawing Mode under Advanced Setting in Graphics Processor Settings. (Photoshop CS6)

Preferences ---> Graphics Processor Settings (lower right box) --->Advanced Settings ----> Drawing Mode drop down menu (change BASIC to NORMAL or Advanced)

fyi. my GPU is the AMD Firepro W8100.