Color profiles for Sony RX100M3 are missing from Lightroom 5.5, and user interface is misleading.

  • 2
  • Problem
  • Updated 4 years ago
I am an experienced photographer. I have processed over 80,000 photos in Adobe products, most taken by better Canon DSLRs and L series lenses.

I became interested in the Sony DSC-RX100 series of cameras, and have been frustrated at how light room behaves. I have all three cameras in the series. Here is a link to a discussion of a confirmed bug Mac Lightromm v. 5.5 affecting the Sony DSC-RX100M3 and user interface issues.

https://forums.adobe.com/message/6591582

The color profiles in the Camera Calibration panel are missing. The Index.dat file for Lightroom omits a reference to the profiles and the profiles are missing from Package Contents. I fixed the problem by copying the profiles from the Library/Application Support/Adobe/CameraRaw/CameraProfiles/Camera into the Lightroom Package Contents and replacing the Lightroom Index.dat with the ACR Image.dat. The missing profiles now appear in the Camera Calibration panel.

I confirmed that Lightroom Image.dat omitted any reference to Sony DSC-RX100M3.

User interface issue. Lightroom gives no feedback on whether or not it is applying profiles for any of the Sony DSC-RX100 series of cameras. In fact, under the Lens Corrections panel, it affirmatively states that no profiles are being applied even though they are being applied, which is misleading. This is inconsistent with the treatment of the RX-1. The panel should show that the appropriate profile is being applied. At least ACR provides a warning, which is inconsistent with interface.
Photo of John N MacKay

John N MacKay

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 2

Be the first to post a reply!