Color picker gets stuck while using brush tool

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)

You can press the option key while using the Brush Tool to switch over to the color picker. If I do this repeatedly, such as stroke, hold option and click to pick color, release option, then stroke, hold option and click to pick a color, release option, etc., the color picker will eventually not go away after releasing option and instead of painting I end up picking colors...  

This is a terrible issue that is preventing me from painting at all because that is a fundamental technique I use for shading and blending colors. Photoshop is pretty much unusable for me because of this issue, it's incredibly frustrating. 

I am running Photoshop CC 2015.5.0 on Mac OS X El Capitan 10.11.5 on a MacBook Pro Retina 15" Mid-2015. This issue happens with or without a tablet connected. I have tried painting using an Intuos Pro and a Cintiq and the same problem happens in all cases. I have tried starting Photoshop in safe mode, reset tools, reset settings but nothing solves the issue.

EDIT: I tried downgrading to Photoshop CC 2015.0.0 and the same problem exists.

Also, it's not only with the color picker. It also happens with undo (⌥Z) where ⌥ gets stuck and I sometimes duplicate the layer when I stroke after pressing undo. I can easily reproduce it by stroking with the brush and undoing repeatedly. Once in a while those keys will get stuck and I end up doing ⌥+drag...
Photo of Nilson Souto

Nilson Souto

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 2
Photo of Ted Martens

Ted Martens

  • 1 Post
  • 0 Reply Likes

I posted this in the same topic on the Adobe forums - reposting here too:

I've had the same problem for years and finally got so frustrated that I googled and found this thread. I'm also using a tablet (Wacom Bamboo Capture Pen and Touch) and can confirm that it happens with tablets but NOT with a trackpad or mouse. I think it also happens with my Huion Pen Display, but I rarely use it and can't remember. With tablets, it's like there's a hiccup at the end of an action where Ps is processes stuff, and if that's the moment when you let go of the Option modifier key, sometimes it 'sticks' and doesn't change back to the Brush Tool (or Pencil in my case). That hiccup itself could be the problem, and the tool sticking the symptom I guess. Sometimes I wonder if it happens more when my RAM or HDD space is running low, but I haven't been able to confirm that either way.

If an Adobe employee wants to see it in action, please let me know and I'd be happy to capture it with video and pass it on to try to figure this out.