Clipping Mask not working

  • 1
  • Problem
  • Updated 4 years ago
Create a rectangle form (vector shape) with round corners + fill with color gradient effect. Then on top in a separate layer, create stripes (bitmap). If you try to create a clipping mask (alt+click between layers) >> the stripes will disappear instead of showing inside the rectangle shape.
Photo of Webrédacteurs Webrédacteurs

Webrédacteurs Webrédacteurs

  • 3 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 685 Reply Likes
Which application are you using?
Which version?
Photo of Dan Smith

Dan Smith

  • 225 Posts
  • 17 Reply Likes
Try putting the stripes layer below the rounded rectangle shape and then clip the rounded rectangle layer to the stripes layer.
Photo of Webrédacteurs Webrédacteurs

Webrédacteurs Webrédacteurs

  • 3 Posts
  • 0 Reply Likes
Sorry :
i use Photoshop CS6 extended (creative cloud suite), last version.

@dan smith : i have the gradient on the stripes (it's not what i need : stripes on the gradient). This used to work on CS 5.1.

I join the file.
Photo of Webrédacteurs Webrédacteurs

Webrédacteurs Webrédacteurs

  • 3 Posts
  • 0 Reply Likes
Ok my bad !

As long as i have the gradient effect, the stripes does not show, even in CS 5.1.

May be i can put this one on the feature request ?

It seems odd to me that the thing that works without the effect does't when an effect is applied. What's more funny is that what @Dan Smith proposed works well (if i inverse the layers )...I suppose that's the way Photoshop is coded...
Photo of Dan Smith

Dan Smith

  • 225 Posts
  • 17 Reply Likes
If you just want the stripes inside the rectangle using your first screenshot, double click on the rectangle layer to the right of the rectangle in the layers panel to bring up the blending options and try the settings below:





Or with just the gradient stripes inside the rectangle copy the vector mask from the rectangle layer to the stripes layer.



Probably numerous other ways as well.