Lightroom 6.5.1: Clipboard cleared after drag

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
After dragging a picture in grid view to another folder, Lightroom silently clears the clipboard for no good reason.

Lightroom 6.5.1, Windows 10.
Photo of martijn Saly

martijn Saly

  • 194 Posts
  • 22 Reply Likes

Posted 2 years ago

  • 2
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1452 Posts
  • 454 Reply Likes
Photo of martijn Saly

martijn Saly

  • 194 Posts
  • 22 Reply Likes
TLDR: No :)

Long answer: it's a totally separate bug. I just happened to report them in quick succession. At least, I wouldn't be able to explain how the two could possibly be related. In fact, it would be bad if they were related.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1452 Posts
  • 454 Reply Likes
Thanks for the clarification. Now I understand what you meant. If I remember this correctly, On Windows, the drag-n-drop uses the same clipboard to store the drag-n-drop (the drag-n-dropped image Ids/paths). It is sort of a standard practice on Windows. I remember there used to be a bug logged against this issue. The bug might have been marked as as-designed.
Photo of thany81

thany81

  • 26 Posts
  • 2 Reply Likes
Then is "as-designed" badly.

Actually drag&drop does NOT use the clipboard. It uses the same APIs and the same data structures, but it does not use the actual clipboard itself. Microsoft is not that stupid ;)
Photo of Harold P Anderson

Harold P Anderson

  • 12 Posts
  • 3 Reply Likes
Definitely a bug. There's no reason (except possibly ignorance or laziness) that drag and drop should be programmed this way.
Photo of martijn Saly

martijn Saly

  • 194 Posts
  • 22 Reply Likes
Any chance this is getting fixed? Any Adobe officials around to confirm?