Lightroom Classic: Chronic "Not Responding"

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)
For the past 6 months and across two computer builds I've been experiencing repetitive "not responding". LR stops responding on imports (reported), LR stops on "enhance details". LR stops responding on pano builds. What happened to this software? Is it time to officially change the LR icon?




Photo of seanhoyt-dot-art

seanhoyt-dot-art

  • 403 Posts
  • 65 Reply Likes
  • very frustrated with the state of things

Posted 7 months ago

  • 1
Photo of Carlos Cardona

Carlos Cardona

  • 777 Posts
  • 149 Reply Likes
Have you ever considered that it might not be a Lightroom issue, but the OS underlying it or the hardware underlying that? As a 25-year Mac IT pro I’ve seen these 2 items to sometimes be the problem.

Let’s start here: Download the free Onyx (https://www.titanium-software.fr/en/o...), select the Onyx version for your OS, download, run it, reboot.
In Onyx run almost everything in the Maintenance tab, deselecting things you may not want deleted, like Launch Services . Hit the "Options" button across from Internet and deselect more stuff like Cookies & Other Site Data, Browser History, Form Values, etc. (most of these are OFF by default). If you don’t know what something is, google it, or don’t run it), then hit Run Tasks. After it's done it will ask for a reboot.

Also try to fix any directory damage by running Disk First Aid from Disk Utility: boot into Recovery Mode, (hold down Command-R when booting). When you're in Recovery Mode go to the Utilities menu and launch Disk Utility, say Repair Disk. When done go to Apple Menu for Startup disk and restart normally.

If Disk Utility says it can't fix it, run Disk Warrior ($120), (https://www.alsoft.com) from an external boot drive, reboot.

Also just doing a "Safe Boot" can clear out caches (restart, hold down shift until you see "Safe Boot" on the screen, let it fully boot, then reboot normally.

If that doesn’t work try launching Lightroom from your other (admin or test) account, with a new catalog, as a test. Does it run OK? If it does it may be a corrupted preference in your Username/Library folder. To reset your LR preferences:

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom.
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.
Photo of seanhoyt-dot-art

seanhoyt-dot-art

  • 403 Posts
  • 65 Reply Likes
  • process 1 raw file to DNG enhanced details - works
  • batch 5 raw files to DNG enhanced details - locked up
It's not my system. It's LR. I've been futzing with mac since mid 80's.
Photo of seanhoyt-dot-art

seanhoyt-dot-art

  • 403 Posts
  • 65 Reply Likes
also: thanks for the tips. I do know that my Disk Utility Repair reports OK for the OS volume.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5659 Posts
  • 2261 Reply Likes
Can you please go to Help menu > System Info and post the contents. Thanks