Photoshop 21.1.0: Choppy Panning when "Flick Panning" is disabled (windows 10, flick panning off)

  • 3
  • Problem
  • Updated 2 weeks ago
  • (Edited)
I've Noticed this weird behavior after the latest 21.1.0 update:

When panning, the canvas  basically refreshes only after I have stopped my panning motion, so that there's no smooth movement during panning, only the state before panning and the state after panning. Feels extremely choppy. Only if I scroll REALLY slowly - like snail speed - I see the canvas following along my motion. As soon as I accelerate to a normal panning speed, the above behavior goes into effect.

I first thought that this might be a graphics card driver issue but then I noticed that when I turn on "flick panning" in the preferences, suddenly panning is performed smoothly (but, as to be expected, with the annoying floaty overshooting motion of flick panning, that I'd like to avoid).

If someone can confirm, this might be an issue worth investigating.
Photo of Daniel Lieske

Daniel Lieske

  • 9 Posts
  • 8 Reply Likes
  • like after every Photoshop update: sad.

Posted 5 months ago

  • 3
Photo of Daniel Lieske

Daniel Lieske

  • 9 Posts
  • 8 Reply Likes
I've asked a friend of mine to test this with his own fresh installation of 21.1.0 and he confirmed that panning feels horribly slow, and the problem does not occur when "flick panning" is activated. 

To test this, all you really have to do is to pan your image both with and without "flick panning" activated (under Preferences > Tools) and compare the performance in both cases. Panning should be smooth in both cases - it always has been - and the only difference should be, that with flick panning activated the canvas starts to coast when you release the mouse button.

Hope some people can confirm so that this problem will be fixed! 
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17068 Posts
  • 2906 Reply Likes
I'm not seeing this on macOS 10.14.x. What OS/version are you running on? Do you know if Use Graphics Processor is enabled or not? Do you have rulers show? Tabbed documents on or off?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17068 Posts
  • 2906 Reply Likes
Not seeing it on Windows 10 either. Need to figure out what's different in our settings besides just disabling flick panning.
Photo of Morris

Morris

  • 14 Posts
  • 9 Reply Likes
Hi.
I have exactly the same problem since PS 21.1 (21.0.3 was buttery smooth).  It is quite frustrating.  Please, take a look into this problem. Thanks.

My Specs
SO: Win 10 1909
CPU: Ryzen 5 1600
GPU: GTX 1060 (Updated to the latest drivers)
RAM: 16 Gb (70% allocated to PS)

What I've tried:
- Every combination of the Advanced GPU settings
- Turning Off GPU Acceleration/Open CL
- Reset Preferences 
- Fresh Installation

What Worked (workaround):
- Revert to PS 21.0.3 
-Turning "Flick Panning" ON

This is a video of the problem:




Photo of Daniel Lieske

Daniel Lieske

  • 9 Posts
  • 8 Reply Likes
Ok, so I'm running Photoshop on Windows 10.

The Graphics Processor recognized by Photoshop is a GeForce GTX 980.

Disabling the Graphics Processor results actually in a slightly better performance - the canvas gets chopped up while panning but there's several frames of interpolation during panning. 

I'm using floating document windows but using tabs doesn't make a difference concerning the problem.

Rulers ON/OFF makes no difference. 

What actually MAKES a difference, and I just noticed this right now, is the window size of the document. With very small window sizes, the problem disappears. My screen is 2560x1440 and when I size my document window to about half that size, the problem is in full effect, getting increasingly better when sizing the window down to something like 300x300px. 
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 127 Posts
  • 61 Reply Likes
Hi Daniel and Morris.  Is this still a problem in the most recent update that came out last week (21.2)?
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 127 Posts
  • 61 Reply Likes
Photo of Daniel Lieske

Daniel Lieske

  • 9 Posts
  • 8 Reply Likes
My main monitor is set to 100% but I've got a second monitor connected on which the OS size is set to 125%. When I set the second monitor to 100%, the situation doesn't change. 

My test is always the same: creating a new document (sized 2400x1800 px), scaling the document window to almost full screen size (on my 2560x1440 px screen), zooming 100% and panning in the document with the hand tool. Panning in version 20.0.6 is smooth, in 21.2 it's unusable slow, unless I activate flick panning.

I really hope you get a grip on this issue. It's the main reason I'm still sticking to 20.0.6
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17040 Posts
  • 2890 Reply Likes
Daniel, are using a gaming mouse? if so, if you setting the polling rate to 125 does it work correctly for you?
Photo of Daniel Lieske

Daniel Lieske

  • 9 Posts
  • 8 Reply Likes
I'm using a Wacom Intuos 5 tablet in Photoshop exclusively. But I actually also have a Logitech gaming mouse connected. I experimented with the polling rate, setting it to 125, but this didn't effect the problem in Photoshop.
Photo of Morris

Morris

  • 14 Posts
  • 9 Reply Likes
Hello.

I have used PS in the past few days. Here's what I found.
It doesn't always work. Even if I set the polling rate to 125 and restart Windows, the problem persists.

From what I understand,  I have to change Polling Rate back and forth every single time after starting Windows:
  1. Open Photoshop
  2. Launch Logitech G HUB
  3. Set polling rate from 125 to 1000 (or other) then go back to 125.