Channel Mixer does not mix correctly in ProPhoto Working Space when mixing monochrome

  • 1
  • Problem
  • Updated 7 months ago
Channel Mixer does not mix correctly in ProPhoto Working Space  when mixing monochrome.

Starting with a file in Ektaspace when I use channel mixer to convert to monochrome with a setting or R100% G 0% B0% the result is exactly the same as when viewing the red channel individually (when selected in the channels window with command-3.) Thsi is the correct behavior


The problem is when I work on a ProPhoto file. The result from the channel mixer is not the same as the red channel, it is lighter and less contrast. It looks like some sort of gamma change happens in the channel mixer. I don't think it should behave this way. If I  enter R100% G 0% B0% I should get only and exactly the red channel data.


Photo of Rich Seiling

Rich Seiling

  • 1 Post
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Cameron Rad

Cameron Rad

  • 53 Posts
  • 6 Reply Likes
So I believe it has to do with your color settings in Photoshop. Mainly the gray working space.

Try changing your Working Space settings to:

Color - ProphotoRGB
Gray - Custom Gamma: 1.8

See if that corrects things.
 
I believe it's best to choose a matching gray working space for your document/color working space. So gray gamma 2.2 for Adobe RGB, 1.8 for ProphotoRGB, sGray (Available online) for DisplayP3/sRGB, etc
(Edited)