Lightroom Classic: Error Changing Modules

  • 7
  • Problem
  • Updated 3 months ago
  • (Edited)
I keep getting a bug whilst changing modules where Lightroom will not respond and I have to close and reopen. I get the error message below and clicking OK does nothing. I'm using a 2017 iMac running Sierra version 10.12.6, any ideas?


Photo of Barry Paffey

Barry Paffey

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 7
Photo of Thomas Hoats

Thomas Hoats

  • 4 Posts
  • 4 Reply Likes
Further information. This is on a late 2103 Mac Book Pro (retina) running High Sierra.

Every three or four LR starts takes we to the welcome screen instead of the last thing I worked on. Clicking OK in the tip results in a screen presentation similar if not identical to the initial screen on a fresh installation. In particular, my account information is missing. Trying to switch to the library causes the Error Changing Modes condition.

Restarting LR usually takes me back to a working session that has my full account info and shows the last picture I worked on.

Why does LR randomly revert to this initial state? It is related to the new LR version being targeted for cloud operation?

In my opinion this is a major flaw in the LR Classic release.
Photo of Henrik Mjöberg

Henrik Mjöberg

  • 27 Posts
  • 2 Reply Likes
I have exactly the same experience running macOS 10.13.1 and Lr Classic CC build 1142117.

You might rule out any syncing issues with Adobe cloud based file service, because I have no files in it and library to cloud syncing turned off.
(Edited)