Changes in Lightroom 5.2 Book Module are not saved

  • 2
  • Problem
  • Updated 5 years ago
  • (Edited)
Win 7 64-bit – Lr 5.2

I repeatedly had it happen that in the Book Module suddenly changes are not saved anymore. I make changes to the book - the changes are displayed correctly as long as I stay within the Book Module As soon as I navigate to another Module and then go back to the Book Module the changes are not displayed and the book has reverted to the state before I made the changes.

Optimizing the catalog and replacing the Preference File did not help. Any changes made to various pages in the book are displayed only while I stay in the Book Module. After changing Modules or after closing Lr and re-open it the book is always in the same state – no changes are saved.

And even funnier: when I delete a page in the book it disappears from the display - as it should. But when I then go to the Develop Module and return to the Book Module the deleted page is displayed again.

BTW: I used the Develop Module in the above only as an example. The same thing happens when I go to Library and back to the Book Module.

Finally it dawned on me: there must something on one of the pages that is doing that. I started to delete single pages from the book one by one. After each deletion of a page I went to the Develop Module and back to the Book Module. At first - as I expected - the previously deleted page was displayed again. Then I hit the "right" page: after I deleted it went to the Develop Module and back to the Book Module the previously deleted page was not displayed anymore.

This was the page that caused the behavior - but I am unable to say what it was on that page that caused this.

I re-created the page from scratch with exactly the same layout, same text, same image. It worked. The changes are now saved again.

In my opinion there is a bug because i should not be able to cause this behavior.

Maybe it is the old bug that was “fixed” in Lr 4.4.
Photo of Ernst Kucklich

Ernst Kucklich

  • 20 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of Ben Tang

Ben Tang

  • 2 Posts
  • 0 Reply Likes
I have a similar problem in Lightroom 5.4. I OK up to 23 pages. If I add any more pages, then I leave the book module or change "duplicate book" copies, the added paged disappear. This is easily repeatable. HELP!
Photo of Ernst Kucklich

Ernst Kucklich

  • 20 Posts
  • 0 Reply Likes
Ben,
In my situation there was 1 page that was corrupted and was the cause of this behavior. To find the page that was causing this I did this:
I deleted page 1 then left the Book Module and returned to it. Page 1 was displayed again. So page 1 was not the problem. Then I deleted page 2, left the Book Module and returned ... In this way I went through the pages one by one. Finally I hit the page that was causing the odd behavior. When I deleted it and left and returned to the Book Module it did not show, i.e. the deletion of this page was correctly saved in the Lr catalog. I then re-created this one page from scratch and all was fine.