Photoshop: PS CC crash when using Quick Mask

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Hi, I have Windows 7 Proffesional and PS CC. I noticed that Quick Mask mode does not working. If I press the icon or press Q, the PS program freezes and several red rectangles appear over the opened image, but no brush is functional. I have to kill the PS from Task Manager. In Task Manager, sometimes photoshop.exe appears to use over 90% of processor power. This happens everytime and ONLY when I want to use Quick Mask. What is the problem?
Photo of Catalin Botez

Catalin Botez

  • 2 Posts
  • 1 Reply Like

Posted 5 years ago

  • 1
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1225 Posts
  • 172 Reply Likes
Does turning off »Use Graphics Processor« in the Performance Preferences and restarting Photoshop have any bearing on the issue?

Are OS and application fully updated and what have you done so far for trouble-shooting?
http://blogs.adobe.com/crawlspace/201...
Photo of Rob Ingle

Rob Ingle

  • 2 Posts
  • 0 Reply Likes
I have the same problem. Using PC Windows 7. I recently updated, thinking it would have been fixed in the latest update, but no. On any selection more complex than a simple object it draws random rectangles then freezes. I use quick mask a LOT, and this is frustrating me to an epic degree. It's making photo editing and manipulation of elements nigh on impossible.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
That sounds a lot like a video card driver issue. Have you tried turning off GPU drawing in Photoshop's preferences?
Photo of Rob Ingle

Rob Ingle

  • 2 Posts
  • 0 Reply Likes
I've tried it off and on all three of the different settings. Same issue. I'm also using a PC which NASA would envy, so I wouldn't have thought the graphics card was an issue.
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1221 Posts
  • 170 Reply Likes
Just to make sure: You restarted after changing the Performance Preferences?
Photo of Catalin Botez

Catalin Botez

  • 2 Posts
  • 1 Reply Like
it worked! Edit/preferences/performance. Graphics processor settings. Use graphics processor is ticked. I opened Advanced Settings. In Drawing mode, the default was advanced. I changed the drawing mode with Normal. Now, quick mask is working!!!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
Glad to hear that fixed it for you.

Is your video card driver up to date?

I'd like to take a look at your Photoshop System Info. Directions for sharing your system info from Photoshop:

http://feedback.photoshop.com/photosh...