cc2019 Bug report: Scale and rotate fail after activating any other window during operation, UI lock, most things can't be activated.

  • 1
  • Problem
  • Updated 1 year ago
cc2019 Bugreport: Scale and rotate fail if you switch to other window during operation, UI lock and most functions can't be activated afterwards.
Photo of Stefan Lundberg

Stefan Lundberg

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
Howdy Stefan,

Can you share more information about the problem you're having?  I can't seem to reproduce it.  What OS are you running?  And which specific version of Photoshop?  What specific steps are you following?

When I try these, I don't see any problem:

1) launch PS
2) open or create an image
3) add text, a blob of pixels, a shape, another image, whatever
4) press CTRL+T and transform it
5) click Edit > Transform > Scale
6) repeat #4 and #5 with another document open and popping between the two

Photo of Stefan Lundberg

Stefan Lundberg

  • 2 Posts
  • 0 Reply Likes
Sorry for the delay, I run on macOS Mojave 10.14.4 and it is Photoshop CC 20.0.4 (Latest I think) and I use the standard essential workspace.

I tried to repeat it today, and it happened immediately (but photoshop had been used for 1 hour prior doing work, but all windows was closed befor I tested). After that I needed to quit and relaunch photoshop, after that I do not manage to do a "clear" repeat where I do know eat whet I did from start.

What I did was (not short-cuts, I used the menu):

Double click to open a picture from digital camera from bridge.
Select all
Edit - Rotate moved it approx 5deg
used Finder window as "ruler"
Continued with rotation
used Finder window
Continued with rotation
(Then I got a dialog to check for OS update from Apple that I tried to ignore, Photoshop freezes for like 10 seconds due to things going on in the background)
The I somehow got out of rotation (probably clicked the tool menu while freezed)
And then boom - almost all menus are greeyed-out and you can basically only do save, and need to quit from the OS dock (right mouse - quit)

The other occasions when this happened did not include the OS Update - request, but always when Im using non photoshop widows during scale/rotate.

But I did not gave up and tested again and after 2-3 min playing with rotate and scale and clicking the photoshop toolbar to escape, it happened and now I'm in the transform mode with menus greyed out- I'm not 100% sure about the sequence to trigger the issue.