Photoshop CC 2019: Blend Modes not working

  • 2
  • Problem
  • Updated 4 weeks ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Photoshop CC 2019: Artifacts on image while using uniform color with Color blending mode

The blend modes Darker Color, Lighter Color, Hue, Saturation, Color and Luminosity aren't working properly when using adjustment layers .

I have both CC 2018 and CC 2019 installed on my Windows 10 System and using any adjustment layer with blend modes works correctly in CC 2018 but not in CC 2019.

For example blending a red or cyan color adjustment layer in blend mode 'Color' produces a grey monochrome effect on the image below. Blending other color adjustment layers in 'Color' blend mode produces weird colours. 

I've also noticed that using other adjustment layers in blend modes Darker Color, Lighter Color, Hue, Saturation, Color and Luminosity produces weird effects as well.

I've followed some threads here in Photoshop Family and enabled Legacy Compositing and that has rectified the problem in CC 2019. Why though?

I don't understand the first thing about Photoshop's compositing engine and why CC 2019 is different so would appreciate it if someone could explain. 

What is the difference between the legacy and non-legacy compositing and will this issue be addressed?

My Graphics driver GeForce GTX 970 is up to date.
The issue is not present in CC 2018 which I still have installed.

Adobe Photoshop Version: 20.0.0 20180920.r.24 2018/09/20: 1193433  x64
Number of Launches: 1225
Operating System: Windows 10 64-bit
Version: 10 or greater 10.0.17134.1
System architecture: Intel CPU Family:6, Model:14, Stepping:3 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, AVX, AVX2, HyperThreading
Physical processor count: 4
Logical processor count: 8
Processor speed: 3 MHz
Built-in memory: 32627 MB
Free memory: 19421 MB
Memory available to Photoshop: 29878 MB
Memory used by Photoshop: 65 %
Alias Layers: Disabled.
Modifier Palette: Enabled.
Highbeam: Enabled.
Image tile size: 1024K
Image cache levels: 4
Font Preview: Huge
TextComposer: Latin
Display: 1
Display Bounds: top=0, left=0, bottom=1200, right=1920
OpenGL Drawing: Enabled.
OpenGL Allow Old GPUs: Not Detected.
OpenGL Drawing Mode: Advanced
OpenGL Allow Normal Mode: True.

Here's my OS specs

Operating System: Windows 10 Home 64-bit
Version 1803
OS build 17134.345

(10.0, Build 17134) (17134.rs4_release.180410-1804)
Processor: Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz (8 CPUs)
Operating System: Windows 10 Home, 64-bit
DirectX version: 12.0 
GPU processor: GeForce GTX 970
Driver version: 372.70
Direct3D API version: 12
Direct3D feature level: 12_1
CUDA Cores: 1664 
Core clock: 1215 MHz 
Memory data rate: 7010 MHz
Memory interface: 256-bit 
Memory bandwidth: 224.32 GB/s
Total available graphics memory: 20409 MB
Dedicated video memory: 4096 MB GDDR5
System video memory: 0 MB
Shared system memory: 16313 MB
Video BIOS version: 84.04.36.00.71
IRQ: Not used
Bus: PCI Express x16 Gen3
Device ID: 10DE 13C2 29783842
Part Number: G401 0010
Photo of Rosa

Rosa

  • 195 Posts
  • 104 Reply Likes
  • Frustrated

Posted 4 weeks ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14549 Posts
  • 1893 Reply Likes
Official Response
Please try the following:

Preferences > Performance... and check "Legacy Composting" - Restart Photoshop. Does the blending work correctly?