Photoshop CC 2017: Save for web - convert to sRGB: profile not being embedded

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
When I have a file (in sRGB or not) and then select "save for web (legacy)" and tick "convert to sRGB", the files that are being saved don't have sRGB embedded.

So when I open them in Photoshop again, sRGB isn't set (no color management is selected) and when I put the files inside a website, the images are displayed incorrectly on monitors set to Adobe RGB.

This is a new bug happening in CC 2017 and didn't happen in CC 2015.5
Photo of Ryan

Ryan

  • 17 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Alex Furer

Alex Furer

  • 152 Posts
  • 39 Reply Likes
There's a checkbox when you export with the legacy exporter to include the profile. That should do it, or something else is broken.
Photo of Ryan

Ryan

  • 17 Posts
  • 0 Reply Likes
Thanks. Just tried that (I'm saving PNGs) but that doesn't fix either.
Photo of Alex Furer

Alex Furer

  • 152 Posts
  • 39 Reply Likes
Hmmm... I gotta run. But maybe it's Photoshop reporting the missing profile while it's there? This should work... Try this tool from Jeffrey Friedl: http://exif.regex.info/exif.cgi
You can upload an image and it will analyze it and tell you reliably whats there.

Or try the new save as... for web in Photoshop. The resetting your preferences dance and so on.

Or you have a similar issue as I with this, which is that the browser is not rendering the image correctly because of the render engine settings in the browser. Here is my thread about this. This is still unresolved for me as well...

Sorry I can't be of much better help right now. I will check back in the evening.
Photo of Pete Green

Pete Green, Customer Advocate

  • 721 Posts
  • 136 Reply Likes
Hi Ryan,

Do you also have Convert to sRGB below the Embed Color Profile checkbox checked? That's required to convert the profile from its current profile. 

Have you updated to Photoshop CC 2017.1?
I'm unable to reproduce in 2017.1 on my Mac 10.12.4.

Regards
Pete
Photo of Ryan

Ryan

  • 17 Posts
  • 0 Reply Likes
I'm on Windows 10.... Adobe Photoshop Version: 2017.1.0 20170309.r.207 2017/03/09:23:00:00 CL 1107877  x64

"Do you also have Convert to sRGB below the Embed Color Profile checkbox checked?"
- Yes
Photo of Ryan

Ryan

  • 17 Posts
  • 0 Reply Likes
This is most certainly a bug in Photoshop :( Causing me real issues.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1111 Posts
  • 359 Reply Likes
As suggested by Alex Furer  try resetting (i.e. restore) your PS Preferences file as outlined here: https://helpx.adobe.com/photoshop/using/preferences.html

When PS starts misbeaving or not applying specific Preferences settings restoring the Preferences file to its 'default' settings often fixes the issue. After resetting it do NOT make any changes to the Preferences settings. See if the sRGB profile is now being assigned with 'Embed color profile' and 'Convert to sRGB' checked in the 'Save for Web' settings.
(Edited)
Photo of Ryan

Ryan

  • 17 Posts
  • 0 Reply Likes
I'm only using Photoshop on Windows 10. Not Lightroom.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1111 Posts
  • 359 Reply Likes
Sorry, I meant PS–I've corrected it. Try the directions at the link provided.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14545 Posts
  • 1891 Reply Likes
Ryan, I just saved a PNG24 and the profile was correctly converted and embedded. Can you select your exported PNG in Bridge and show a screen cap of the File Properties? Here's mine from a file saved from Save For Web in CC 2017.1.1:

Photo of Todd Shaner

Todd Shaner, Champion

  • 1111 Posts
  • 359 Reply Likes
Ryan, is it now working correctly (i.e. converting and assigning sRGB) to all of the slices after resetting PS 2017 Preferences file?
Photo of Ryan

Ryan

  • 17 Posts
  • 0 Reply Likes
Yes, all working. I don't think the issue was the Preferences file. I think it was that I just had to select EACH slice and make sure "Embed Color Profile" was ticked on for each one (instead of just ticking it on for the entire document and thinking this would apply it to all slices).

I hope this makes sense.
Photo of Ryan

Ryan

  • 17 Posts
  • 0 Reply Likes
Note: Cleaning the Preferences DID make Bridge report the program as Photoshop CC 2017 instead of Photoshop CC 2015.5. But personally I didn't really care about this.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1111 Posts
  • 359 Reply Likes
I had a chance to look at this some more and there's definitely a bug in the legacy 'Save for Web.' PNG-24 seems OK, but PNG-8 appears to be not converting some of the slices to sRGB, but the slices are being assigned the sRGB profile anyhow. I'm working on a wide gamut display, which makes this "bug" very apparent. If using a standard gamut display it would most likely not be apparent (i.e. it is close to sRGB gamut). I've go to run out so can't investigate further now. Please provide complete details how you are slicing the image, using layers, etc.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1111 Posts
  • 359 Reply Likes
After looking at this further the issue is just as you describe. When in the 'Save for Web' output panel it is necessary to select each slice and adjust the settings as required individually. In my test image (255, 0, 0 Fill) some of the panels were set to PNG-8 and some to PNG-24, which produced a noticeable difference in the image hue. Sorry for any confusion.