PHOTOSHOP CC 2015, Step Backwards keyboard shortcut doesn't work.

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
On OSX.

the default keyboard shortcut for step backwards on photoshop cc 2015 doesn't work.
Photo of Tim St Clair

Tim St Clair

  • 10 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 2
Photo of eartho

eartho

  • 814 Posts
  • 198 Reply Likes
works fine for me.
Photo of Tim St Clair

Tim St Clair

  • 10 Posts
  • 0 Reply Likes
Here's the steps I have taken.

1. Bought a new mac.
2. Installed Creative Cloud
3. Installed Photoshop CC 2015
4. Opened a file in photoshop
5. Made two changes
6. Pressed the keyboard shortcut for "step backwards".

Nothing happens for me. It only works if I use the menu option.
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Howdy Tim,

What happens?  I do this every day and haven't had a problem.

Have you tried resetting your keyboard shortcuts.  Go to Edit > Keyboard Shortcuts and under the Edit menu, what is listed for Undo/Redo?  Step Forward?  Step Backward?

Thanks,
David
Photo of Tim St Clair

Tim St Clair

  • 10 Posts
  • 0 Reply Likes
Here's exactly what I am doing.

1. Launch photoshop.
2. Make a new file using CMD-N
3. Accept the defaults
4. Press M. Make a selection.
5. Choose a colour from the library
6. Press OPTION-DELETE to fill the selection with the foreground colour.
7. CMD-D to deselect.
8. CMD-DELETE to fill the entire image with the background colour.
9. Hold the CMD key, with the OPTION key, and tap the Z key.

Nothing happens. I expect that the background fill would undo. If I then step backwards using the edit menu, then press SHIFT-CMD-Z, step forward also does not work.

I have already gone to photoshop > edit > keyboard shortcuts and CHANGED the shortcut for step backwards, saved this, exited, came back in, hit reset, saved, exited and come back in then confirmed that this does NOT fix or reset the problem. I havealso gone to edit > keyboard shortcuts, held the OPTION key and pressed RESET (in place of the cancel button). This also has had NO effect.

I have already gone to the system preferences > keyboard > Shortcuts and confirmed there are no other shortcuts defined for either of these combos, and have restored the defaults anyway, with no discernable effect.

Here's the export of what my photoshop keys are currently set at: http://175.45.134.80/~frumbert/Photos...
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Hi Tim,

I followed your precise steps on Mac OS 10.10.3 without the slightest problem.  Everything worked as expected.  It sounds like that some other applet or utility is intercepting your keyboard commands so PS isn't getting them.  Common offenders are keyboard or voice capture apps as well as many tablet utilities.  Again, I do this same thing every day and have never had a problem.  Moreover, it's an immensely common shortcut; if it were broken, I would expect the forums to be on fire with complaints.  

Thanks,
David
Photo of Tim St Clair

Tim St Clair

  • 10 Posts
  • 0 Reply Likes
So how do I go about resolving this? I bought a brand new mac just a few weeks ago now. It came with OSX 10.10.4, it's that new. I didn't restore my previous profile from my time machine, i creataed a brand new profile and installed individual apps freshly. I have not knowingly put anything like a keyboard changing utility. I just have normal web development tools onto it (you know, sublime, transmit, that sort of thing) and the CC 2015 suite. I can't figure out what could be blocking the combo in photoshop, but it just does not work in photoshop (and only photoshop). i'm happy to trash photoshop and try again, once I work out how to delete all the litter it puts in my system (preferences and so on) to ensure it's a clean install.
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Hi Tim,

Things I would try if this were me...:

1) Test the effectiveness of both CMD+Z and F1 as shortcuts -- try and reset these shortcuts to some other command, such as File > Open and see what happens.  If they fail in the same way there, then slam-dunk, you've got something else on your machine "eating" the keyboard commands, no other option.

2) Test the shortcut for undo with some OTHER combo -- I'd use CMD+OPT+SHIFT+O or CMD+OPT+SHIFT+U cuz they are unused by any other command.  Does that work?  If so, then, again, the only option is that your keyboard command for CMD+Z is being "eaten" by another utility.

3) Reset your keyboard shortcuts to default -- Edit > Keyboard Shortcuts and choose Photoshop Defaults under the Set dropdown.  This makes sure that there's nothing odd with your setup.  You might also want to trash your preferences -- launch PS while holding down CMD+OPT+SHIFT

4) From here, I would take a HARD look at what else is installed on your machine.  I'm unfamiliar with Sublime and haven't used Transmit in a while, but if you get here, then clearly SOMETHING is co-opting your keyboard commands.  Ping me here and I can set up a web-hosted connect-session to help you troubleshoot the problem.

Thanks,
David
Photo of Anthony Sbarro

Anthony Sbarro

  • 5 Posts
  • 3 Reply Likes
Did you find a fix for this Tim? This has been driving me nuts.
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Hi Anthony,

Have you tried the steps that I outlined for Tim, above?  What happens when you try each of the four ideas?

Thanks,
David
Photo of Anthony Sbarro

Anthony Sbarro

  • 5 Posts
  • 3 Reply Likes
I was able to remap Step Backwards to F10.

When I tried to go back to OPTION+COMMAND+Z, I was unable to remap or use any commands with the OPTION key. OPTION does work for Finder functions.
Photo of Anthony Sbarro

Anthony Sbarro

  • 5 Posts
  • 3 Reply Likes
Got it. In my case it was due to an app I had installed called Spectacle. Although, I'm quite certain I had this same issue prior to the installation of this app. It's working now so I guess that's that.

Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Thanks for the heads up, Anthony.

Third party apps misbehaving is probably the number one cause of the bugs I deal with.  Knowing the name of one can help other users with similar problems.

Thanks,
David
Photo of Brendan Micallef

Brendan Micallef

  • 1 Post
  • 0 Reply Likes
I just got off customer support for this issue, it was very annoying and forced me to use Photoshop CS2 in the meantime. However the helpful man at the other end figured to rename the preferences folder, adding '_old' to the end of it, and restarted Photoshop. This fixed the issue for me. Apparently the preferences were corrupted.

Tate.