Photoshop CC 2015: Recent update switched off GPU Rendering

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Hi All

After the new update CC 2015 suddenly has stopped recognising my Graphics Card Radeon HD7750 rendering me unable to use some facility's, I have found the problem to be my other onboard graphic card Intel hd, as when disabled CC 2015 then recognises my primary card, the problem is that I use the two screens so obvious choice of leaving the onboard disabled does not really solve the problem.

Does anyone know of a fix or work around for this?

Many Thanks
Steve
Photo of Stephen Smout

Stephen Smout

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
Did you update the drivers for both of your cards/GPUs from the GPU maker's websites?
Photo of Fabio Viero

Fabio Viero

  • 6 Posts
  • 0 Reply Likes
I just updated Ps and my video drivers were already up to date. Photoshop won ́t even start. It opens up to show the menus but the screen keeps flashing gray and white. It also switched off GPU rendering (Radeon HD 5770). The update rendered Ps unusable. Needs fix.

GPU rendering was a shame when introduced in Lr. It used to work in Ps but it seems to be going the same way.
Photo of Fabio Viero

Fabio Viero

  • 6 Posts
  • 0 Reply Likes
Hey, Stephan. Thanks for your reply. The biggest issue for me wasn ́t really the GPU being switched off. It was much more worse. Ps canvas would keep flickering gray and white and it was difficult to even click to open up any top menu. When i managed to get into Preferences - General, i just unchecked "Show start workspace when no documents are open" and it did the trick. About the GPU being turned off, it only warned once. I can disable and re-enable GPU support...Ps won ́t say a word about it. Right now options are set to use it. So, in short, my problem was solved by unchecking that option i mentioned a few lines ago.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
OK, turning on or off the start workspace shouldn't have an effect on an open document (because the start workspace goes away after something is opened). We'll have to see if we can reproduce the flickering that you're seeing.
Photo of Fabio Viero

Fabio Viero

  • 6 Posts
  • 0 Reply Likes
What happened here, step by step.

- Updated Ps yesterday
- Ps canvas starts to flicker when you fire up Ps
- Ps warned that GPU Rendering was disabled
- Flicker continues
- Quit Ps
- Start Ps. Flicker continues.
- Preferences - Performance and manually disabled GPU rendering
- Restart Ps
- Flicker continues
- Manually enabled GPU Rendering
- Restart Ps
- Flicker continues
- Google search till i found a KB article: https://helpx.adobe.com/creative-clou...

My problem is actually solved, but this is a workaround...not a real solution.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
Did you disable Windows Narrator? Did that solve the flicker?
Photo of Fabio Viero

Fabio Viero

  • 6 Posts
  • 0 Reply Likes
No, Chris. Solution 2 found in the link.

Solution 2: Disable the Start workspace

Go to Edit > Preferences > General
Uncheck the "Show "Start" Workspace When No Documents Are Open" option.
Restart the application.
Photo of Stephen Smout

Stephen Smout

  • 4 Posts
  • 0 Reply Likes
Hi Chris

I Did update both the onboard and the Radeon card from manufacture's sites but has made no difference at the moment lightroom works but PS will not.

OS is windows 10 64 bit everything is fully updated, for some reason the gpu sniffer in the updated version of PS cc 2015 is not able to recognise the primary card as soon as I disable the onboard it works.

So far the only work around I can think of is to buy a new second monitor which will connect to the primary card via HDMI and disable the onboard.

The set up worked flawlessly before the update I don't think I will be applying the next update to lightroom in case the same happens to that.
Photo of Stephen Smout

Stephen Smout

  • 4 Posts
  • 0 Reply Likes
I have now re-installed the previous version from the CC app and everything is now working as it should, added bonus got the old GUI back was not overly impressed with the new one just my opinion.

This does mean though That I will not be able to update to any new versions but I would rather have a fully working program than a half working one.

Hope this helps other people with the same problem.

Steve