LIGHTROOOM: Catalog integrity: fixing and so on

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
Recently I had a problem while saving the copy of the catalog, optimize it and check for errors (the process that we're able to do when we quit from LR). I'm using LR 4.4RC. The checking gave me error, so I wasn't able to finish correctly this process. After, load LR again, the app tells me that it can not load the catalog because of the errors. Ok. Don't panic. I do catalog backup everyday. So I load the catalog from yesterday (the latest). First message on screen: catalog wasn't closed correctly last session (I know, I know, but it was the other catalog, not this one!) so Lr must check integrity. Ok. Some error found! Here too? I click over the "Correct errors" button and wait finger crossed. Errors fixed. Ok. Fine.

Two days later I found that despite LR is running as always, I've lost all the histories from the catalogs. All the changes are correct in the sliders (on develop module), but history list is empty...

I don't know if it's a great loss or not for me... but I think it can be a big problem!
Photo of ImanolZ

ImanolZ

  • 71 Posts
  • 5 Reply Likes

Posted 6 years ago

  • 1
Photo of ImanolZ

ImanolZ

  • 71 Posts
  • 5 Reply Likes
I had 2 catalog errors this day.

In the first case, I entered in LR 4.4, edit some photos. When I entered again, Lr tells me about a catalog error (nothing happened when I closed before, not error messages, nothing). So LR made a catalog fixing (I lose all the histories again) but catalog fixed.

In the second one, while editing one photo, LR exited with error message and when entered again, catalog error message but in this case, there's no fixing. It cannot be fixed. So I lost all the changes I made since yesterday. Again. It's not the first case that I have. Until LR 4.4RC I hadn't had any catalog error... and since 4.4RC I have lost the count.

What I can do?