Lightroom: Caption Problem in Lightroom 3.6RC

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
I used LTR 3.3 on a Mac. OLYMPUS E-P1 photos by default have an "OLYMPUS ..." caption, but I can delete the caption in LTR, and the exported JPEGs will not have the annoying caption (EXIF ImageDescription and IPTC Caption). I recently try the 3.6 RC on a new Mac, and found that the caption existed in the exported JPEGs in this case. The caption can only be replaced if I put a new caption in LTR, but it cannot be removed.

I consider this a regression bug.
Photo of Yongwei Wu

Yongwei Wu

  • 5 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of John R. Ellis

John R. Ellis, Champion

  • 3589 Posts
  • 928 Reply Likes
I have a bunch of those annoying Olympus-captioned images, and I was able to reproduce the problem in LR 3.6 (released). Note that "OLYMPUS" shows in both the LR Title and LR Caption fields in the metadata pane.

If you clear both title and caption and export to a file, the exported file still has "OLYMPUS" in the fields.

But if you do Metadata > Save Metadata To File after clearing, then it's properly removed from the exported file.
Photo of Yongwei Wu

Yongwei Wu

  • 5 Posts
  • 0 Reply Likes
Oh, thanks, John. That serves as a good workaround.

Since 3.3 works well, can some Adobe LTR developers look at this and solve it from the root? :-)

(Are there any Adobe employees looking at this?)
Photo of John R. Ellis

John R. Ellis, Champion

  • 3589 Posts
  • 928 Reply Likes
In general, Adobe employees frequently participate here (and many bugs get fixed as a result). Since you marked this as a problem, I think it's very likely they'll at least read this.
Photo of Yongwei Wu

Yongwei Wu

  • 5 Posts
  • 0 Reply Likes
Thanks. It is good to know.
Photo of Yongwei Wu

Yongwei Wu

  • 5 Posts
  • 0 Reply Likes
I post to confirm that the caption issue starts at least from 3.4.1.
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Have either of you installed the Lightroom 4 Beta? The issue doesn't happen for me in that version, but I'd be interested to hear if your results are different.

Thanks!
Photo of Yongwei Wu

Yongwei Wu

  • 5 Posts
  • 0 Reply Likes
Hi Becky,

I finally borrowed a Snow Leopard MacBook and had a try (regretfully you stopped supporting Leopard). The result is the same as 3.6RC. For Olympus raw photos with a built-in caption, clearing the caption does not affect the exported JPEG files.

John's suggestion still works. The bad part is that I will have a lot of .xmp files all over my disk.

I wish you could have a chance to fix it. Sometime in the future I may have new camera that forces me to upgrade.

Thanks!
Photo of John R. Ellis

John R. Ellis, Champion

  • 3589 Posts
  • 928 Reply Likes
This also happens to me with LR 4 beta, Windows 7 64-bit, with a new metadata-status bug that didn't appear in LR 3.6 (see step 5 below):

1. Import the attached file into the catalog. Observe that Title and Caption are "OLYMPUS DIGITAL CAMERA".

2. In the Metadata pane, delete the Title and Caption. Observe that the metadata status changes to "Has been changed".

3. Do File > Export as JPEG, without resizing, with Metadata = All, and Remove Location Info and Write Keywords As Lightroom Hierarchy unchecked.

4. Observe that the fields EXIF:ImageDescription, IPTC:Caption-Abstract, and XMP:Description all have the value "OLYMPUS DIGITAL CAMERA".

5. Do Metadata > Save Metadata To File, and observe that Metadata Status briefly changes to "Up to date" and then back to "Has been changed". This new bug wasn't present in LR 3.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3589 Posts
  • 928 Reply Likes
The forum software is stripping metadata from JPEGs! Here's the test pic to use:

http://dl.dropbox.com/u/21811200/capt...