Lightroom: Can't setup 500px Plugin ("This plug in is malfunctioning and cannot be used").

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
I deleted my 500px Publishing Service, because it was not functioning correctly, then tried to re-add it, and I get this error in Publishing Manager: Can't setup 500px Plugin (This plug in is malfunctioning and cannot be used). If you export the Diagnostic Log, you get this:

"Error 1. An error occurred while attempting to load this plug-in.The plug-in description script (Info.lua) is missing." Please see attachment.

MacOS 10.12.4, iMac 21" Retina, using Intel Iris Pro Graphics 6200 Processor.

Note that I re-downloaded the plug-in from 500px.com, so it is the most recent one. Also note that I recently reset my LR Preferences to show the profile on Canon G3X shots (which now again doesn't show properly!) My Flickr plug-in works fine.

Thanks in advance for your advice!

Photo of Carlos Cardona

Carlos Cardona

  • 286 Posts
  • 52 Reply Likes

Posted 1 year ago

  • 1
Photo of Todd Shaner

Todd Shaner, Champion

  • 1072 Posts
  • 346 Reply Likes
Carlos it looks like there's a compatibility issue with the  500px LR Plugin:

https://feedback.photoshop.com/photoshop_family/topics/lr-500px-plugin-not-working-currently-any-wor...

It may also be corrupting your preferences file and causing the issue with the Canon G3X lens profile. Try removing the 500px plugin, reset LR Preferences file, and see if the lens profile now works properly.
Photo of Carlos Cardona

Carlos Cardona

  • 286 Posts
  • 52 Reply Likes
Todd: Nah, that looks like a long shot to me! I reset the prefs 3 times already, and the G3X lens profile continues to break. My workaround is to give 500px permission to import from Flickr, and upload to Flickr first!