Photoshop: Can't see anything on MacOS Catalina

  • 1
  • Problem
  • Updated 9 months ago
  • (Edited)
Started the free trial for PS 2020 on MacOS Catalina, and I can't see my canvas.

It sucks because I already bought the CS6 suite before the Catalina update, but after the update I had to remove all things CS6. Now I'm wasting my free trial for the new Photoshop on a canvas I can't even see. How to fix??

Photo of Isabel Araneta

Isabel Araneta

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 9 months ago

  • 1
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2971 Posts
  • 1270 Reply Likes
This may be a GPU issue. Change the graphics processor settings in Preferences - Performance to see if that helps.
Photo of Yves Crausaz

Yves Crausaz

  • 786 Posts
  • 113 Reply Likes
Est-ce que votre mac est éligible pour cette nouvelle version de PS ?
Avez-vous répondu à toutes les demandes d'autorisation faites lors du premier lancement du logiciel ? Il y a beaucoup de nouveaux comportement à avoir avec l'arrivée de Catalina !

Is your mac eligible for this new version of PS?
Did you answer all requests of approval made during the first launching of software? There is behaviour new a lot to be had with Catalina's arrival!

Personally having control all pre-requesting to Adobe, I had no worries on my iMac on 2019.

Photo of PECourtejoie

PECourtejoie, Champion

  • 906 Posts
  • 335 Reply Likes
Hello, can you post the contents of help>system info, so that we can see your screen size.
I would also delete the preferences: Photoshop>preferences>general , click on delete preferences on quit.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2917 Reply Likes

It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help > System Info... and copy/paste the text in a reply.

Photo of Isabel Araneta

Isabel Araneta

  • 3 Posts
  • 0 Reply Likes
Yeah, I just downgraded back to High Sierra. It was too much of a hassle. Thanks for the fast replies though!