Photoshop CC 2014: Cant open password protected PDF documents

  • 2
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
When I open a password protect PDF in photoshop 2014 I get the password dialog and then nothing, if I save the PDF without a password its all fine so I know the PDF is fine to be opened in Photoshop, this has only started to occur in the latest version 2014 1.0
Photo of Richard G Silk

Richard G Silk

  • 3 Posts
  • 1 Reply Like
  • frustrated

Posted 4 years ago

  • 2
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1208 Posts
  • 166 Reply Likes
I can’t reproduce the issue (2014.1.0 on Mac OSX 10.8.5).
Could there be other issues with either the pdf or your set-up, what have you done for general trouble-shooting so far?
Photo of Richard G Silk

Richard G Silk

  • 3 Posts
  • 1 Reply Like
Hi Christoph,

Thanks for the reply.

I am on OS 10.9.4 if that makes a difference, I have tried both drag and drop and open from the open file dialog, the PDF themselves are not at fault as I have removed the security and saved the PDF and it works fine, this also occurs over different PDF's.

I have been using Photoshop long enough I know this has worked over at least 5 previous versions of Photoshop, this did work on the previous CS photoshop as well.

Machine has been restarted several times and the files are local too.

The machine is also a brand new mac pro configured with more than enough resources to handle 1mb PDF.

Its certainly strange as I don't believe the specific functionality would have been updated in the latest PS

Thanks
Photo of DEREK FLEAGLE

DEREK FLEAGLE

  • 2 Posts
  • 1 Reply Like
I'm having the same issue. Was this ever resolved?
Photo of Richard G Silk

Richard G Silk

  • 3 Posts
  • 1 Reply Like
Hi Derek,

Apologies forgot about this thread, yes the latest update photoshop 2014.2.0 has resolved this issue, guess they were either listening or already aware of it :)

Cheers

Richard
Photo of DEREK FLEAGLE

DEREK FLEAGLE

  • 2 Posts
  • 1 Reply Like
Hi Richard,

Thanks so much for getting back to me. I could have sworn that I was on that version already, but there was actually another update today 2014.2.1, and that actually fixed it for me, so either way, thank you :)

-Derek