Can't locate OS shortcut key to override

  • 1
  • Question
  • Updated 2 years ago
Trying to override a default OS shortcut key with a Photoshop one. Just got CC and all my previous versions I didn't have this problem. I understand if I go to System Preferences > Keyboard > Shortcuts, I can remove the shortcut, but I just don't have it. The shortcut I want to add is Command +F1. I have successfully added other Command + shortcut keys, but this one gives me the error "cannot be assigned because it is used by os". I am on a laptop and already have clicked on the "Use F1, F2..." checkbox on System Preferences. Thanks for any help!
Photo of yongjoo2000

yongjoo2000

  • 3 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of grauenwölfe

grauenwölfe

  • 216 Posts
  • 79 Reply Likes
What happens when you press ⌘F1? Does it seem to have any noticeable result in Finder or anywhere else in the OS?

Maybe open Console an try that key combo and see if Console logs anything.
Photo of yongjoo2000

yongjoo2000

  • 3 Posts
  • 0 Reply Likes
Nothing appears to be happening when I press ⌘F1 in the Finder. I was able to change this shortcut on my iMac at work with CC, but the laptop won't allow. I do get this in console, but doesn't seem very helpful to me.

666: Device is currently muted

Any thoughts?

Photo of yongjoo2000

yongjoo2000

  • 3 Posts
  • 0 Reply Likes
Ok, my audio was muted, and i have unmuted. Getting coreaudio requests, which seems strange that the hotkey is associated with this. Don't even know where to turn it off
Photo of grauenwölfe

grauenwölfe

  • 216 Posts
  • 79 Reply Likes
Have you tried it with the -fn- key depressed? You said it's already set to "Use F keys" but may still be worth a shot. Any audio software or devices installed, past or present? You may need to look through your preference files, Launch folders, Login Items, Extensions etc. for any forgotten about (and possibly Satanic?) devices.
Photo of grauenwölfe

grauenwölfe

  • 216 Posts
  • 79 Reply Likes
Satanic thing was a joke about the error code or whatever... "666: Device is currently muted."

Anyway, I think this reply may have been meant for this thread, not sure. Reply from David Tristram here: select and mask

Command F1 is mapped to toggle display mirroring.  I saw this note in discussions.apple.com/thread/2793101

Use KeyRemap4Macbook (now known as Karabiner). It takes a while to learn how to use it, but it's very powerful. The following custom setting in private.xml works for me to simply disable this keyboard shortcut: 
     <item>
          <name>Disable Mirroring Shortcut</name>
          <identifier>private.disable_mirroring_shortcut</identifier>
          <autogen>--ConsumerToKey-- ConsumerKeyCode::BRIGHTNESS_DOWN, VK_COMMAND, KeyCode::VK_NONE</autogen>
     </item> 
Photo of David Tristram

David Tristram, Employee

  • 118 Posts
  • 55 Reply Likes
thanks grauenwölfe