Elements 13: Can't install trial

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
Tried several times to install trial Photoshop elements 13 with and without the downloader too. After files are extracted I Keep getting an error message : installer failed to initialize. Please Help!!
Photo of Rocco benedetto

Rocco benedetto

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
What OS/version?
Photo of Rocco benedetto

Rocco benedetto

  • 6 Posts
  • 0 Reply Likes
Windows 8.1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
Have you tried a different browser? Are you running any antivirus? It sounds like the installer is being modified somehow.
Photo of Rocco benedetto

Rocco benedetto

  • 6 Posts
  • 0 Reply Likes
Yes, tried IE Explorer and Chrome and turned off my Avast anti virus. Same problem
Photo of Rocco benedetto

Rocco benedetto

  • 6 Posts
  • 0 Reply Likes
I've been searching for a solution on the net. Several people are having problems installing Elements 13. Sure hope you guys resolve this soon. Guess I'll continue to use paint shop pro for a while longer.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
I'll have someone work with you 1:1 to see if we can solve it for you. In these cases it's usually something system specific.
Photo of Rocco benedetto

Rocco benedetto

  • 6 Posts
  • 0 Reply Likes
It has been 25 days. No one has contacted me. Tried again today to install elements. same result.
Photo of k conner

k conner

  • 2 Posts
  • 0 Reply Likes
I can't install either. Keeps telling me my computer is offline when I know it isn't.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
So something on your computer is preventing it from contacting Adobe's servers. That could be a bad firewall setting, a bug in a utility program, or a bogus entry in the hosts table.
Photo of Rocco benedetto

Rocco benedetto

  • 6 Posts
  • 0 Reply Likes
Thank you for the reply. I have no idea how to check for any of these problems. Is there some sort of instruction for fixing the problem. Is there some workaround?
Photo of k conner

k conner

  • 2 Posts
  • 0 Reply Likes
Yes. I had it installed once before with no problem then had to reinstall after installing Window 7 Premium. Can't get any Adobe product to work. All other software installed just fine from other companies. I know I have an issue with Adobe, just don't know how to fix. Even tried installing in safe mode.