Lightroom: Cannot sign in to Lightroom Mobile on desktop "Sign in failure. Please try again later. (attempt to index a nil value)" - Mac OS

  • 9
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
I cannot sign in to Lightroom Mobile from my desktop. I tried rebooting, re-installing LR, resetting preferences and re-login. Nothing. This is the error:


So, the error I receive after clicking on Sign In is "attempt to index a nil value".

System info:
Lightroom version: 5.4 [955652]
Operating system: Mac OS 10
Version: 10.9 [2]
Application architecture: x64
Logical processor count: 8
Processor speed: 3,4 GHz
Built-in memory: 32768,0 MB
Real memory available to Lightroom: 32768,0 MB
Real memory used by Lightroom: 326,2 MB (0,9%)
Virtual memory used by Lightroom: 916,0 MB
Memory cache size: 81,7 MB
Maximum thread count used by Camera Raw: 4
Displays: 1) 2560x1440

Application folder: /Applications
Library Path: /Users/hans/Pictures/Lightroom/Vrij Werk/Vrij Werk.lrcat
Settings Folder: /Users/hans/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) Behance
2) ColorChecker Passport
3) HDR Efex Pro 2
4) rc Raw Plus Jpeg

Config.lua flags: None
Photo of Hans van Eijsden

Hans van Eijsden

  • 32 Posts
  • 4 Reply Likes
  • frustrated

Posted 6 years ago

  • 9
Photo of Alain Zarinelli

Alain Zarinelli

  • 14 Posts
  • 3 Reply Likes
Everybody who has trouble signing in...

Did some more debug work with Adobe.

Can you all check you computer name? If you have none, try adding one - "System Preferences", then "Sharing".

Make sure you have a name in there. Once I added one, LR5.4 connected fine...

Photo of Philip Smith

Philip Smith

  • 8 Posts
  • 0 Reply Likes
Worked for me. Still think they need to release a patch.
Photo of David Brant

David Brant

  • 3 Posts
  • 0 Reply Likes
You genius! I added a name, and it works fine now.! grazie mille!!
Photo of Alain Zarinelli

Alain Zarinelli

  • 14 Posts
  • 3 Reply Likes
Yes, the engineer I worked with did mention they are looking into how best to roll out a fix for this. Keep in mind that for the vast majority of users, it worked fine all along - we are a very small minority of users that have (had!) this issue, so I think we need to commend Adobe for assigning engineers to look into this and help us resolve it...

I for one am grateful they didn't just dismiss our issue due to the small number of cases!
Photo of Benjamin Reed

Benjamin Reed

  • 4 Posts
  • 0 Reply Likes
Holy cow! I had *just* reset my network and sharing preferences the previous day because of other problems I was having. I did notice, yesterday, that my hostname was showing up as "localhost" so I went back in and added a name in the Sharing panel. I didn't connect that to my login working again. Good catch!