Lightroom: cannot rearrange SOME photos

  • 2
  • Problem
  • Updated 8 years ago
  • Solved
  • (Edited)
I am using Lightroom 3. I have registered it but it is not showing up in my account (LR 2 is showing up). I have 7000 photos in a collection which originated from several folders on the PC (WIn 7, 64 bit).

Tonight I am unable to rearrange SOME photos. They will not move in filmstrip or grid view. Others move fine. Also, some jump to random locations in the collections when I try to move others. Some photos will move to nearby locations but not where I try to place them. I get the dark border edge at the location where I want to move the photo, but the photo will not move.

I have checked the integrity of the catalog several times and have restarted LR several times. This used to work. It is VERY frustrating, as I can no longer edit my photo collection, since the photos are scattered around, rather than in the 'User Order' that I have set.

HELP! I cannot afford the time to rebuild my 7000 image library.
Photo of Herschel Weintraub

Herschel Weintraub

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 8 years ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1374 Posts
  • 344 Reply Likes
A couple of items to consider when rearranging images.

1. You must be in a static collection to rearrange photos. You cannot be in folder view. You cannot be in a smart collection. You cannot be in a collection set.
2. You must drag the image thumbnail and not the image cell in order to move them.

If you follow those two constraints you should be able to rearrange images in either Library-Grid or in Film Strip.

If, however, you are in a single static collection and are dragging the image thumbnail and still unable to rearrange an image-even with User Order specified in the grid tool bar, let us know.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5339 Posts
  • 2114 Reply Likes
If you're still unable to move after trying Rikk's suggestions, also try creating a new collection and dropping the same photos into it. Sometimes that'll do the trick.
Photo of Herschel Weintraub

Herschel Weintraub

  • 2 Posts
  • 0 Reply Likes
Hi Rikk and Victoria

I was in a static collection and trying to drag the image thumbnail. Most images will rearrange. A few of them wouldn't. I had a mixture of jpg and NEF files in my collection (from my Coolpix 8800 and D90).

I tried the following last night: I exported all of the jpg files as DNG's and re-input them. I had about 450-500 of them. It took some time, but I inserted them into the collection where they "belonged" and removed the jpg's from the collection.

This seems to have corrected the problem - at least the images that I was unable to move can now be moved. Perhaps something got scrambled or the database entries for the jpg's in question were somehow corrupt (I had validated the database several times when I was unable to move the images).

I have a backup of the catalog just in case and will report back if I encounter the issue again.

Any thoughts as to what might have caused the glitch?

Thanks for the reply