Photoshop Elements: Cannot open edit for pse 9?

  • 2
  • Question
  • Updated 6 years ago
  • (Edited)
i can open organize but cannot open edit from either the start up page or in organize. i have re-installed this program several times and it still doesn't work.can anyone please help with this?
Photo of stuart morgan

stuart morgan

  • 4 Posts
  • 1 Reply Like
  • frustrated

Posted 7 years ago

  • 2
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
Do you get an error message when you try to open the Editor?

Do you see the splash screen?

Are you on Windows or Mac?
Photo of stuart morgan

stuart morgan

  • 4 Posts
  • 1 Reply Like
no error or splash screen, it looks as though it is opening but then stops and nothing happens, organise works fine. windows xp.
Photo of Paul Johnston

Paul Johnston

  • 6 Posts
  • 0 Reply Likes
I have the same issue. Win 7 64bit.

Used to be fine - perhaps a dodgy update?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1667 Reply Likes
Try restoring the Editor preferences:

http://help.adobe.com/en_US/Photoshop...
Photo of stuart morgan

stuart morgan

  • 4 Posts
  • 1 Reply Like
did as told and nothing happened
Photo of Paul Johnston

Paul Johnston

  • 6 Posts
  • 0 Reply Likes
Ok - after some testing I think it is linked to User Account Control.

If I disable UAC and reboot my PC then editor works fine,

If I then enable UAC again (it's at the default level) then the problem occurs again.

Obviously I want UAC on...

By the way I have admin rights.
Photo of Paul Johnston

Paul Johnston

  • 6 Posts
  • 0 Reply Likes
Thanks Jeffrey for the pref tip. I tried this too but no luck.

Actually I didn't get the message your page said I would get. However when opening the organiser I got a message to choose catalogue again so something happened.
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
If the keyboard shortcut isn't working, you can manually reset the preferences as well. Navigate to:

WinXP- C:\Documents and Settings\[User Name]\Application Data\Adobe\Photoshop Elements\9.0\Editor
WinVista/7- C:\Users\[User Name]\Roaming\AppData\Adobe\Photoshop Elements\9.0\Editor

and rename the file "Adobe Photoshop Elements 9 Prefs.psp" to "Adobe Photoshop Elements 9 Prefs.old".
Photo of Paul Johnston

Paul Johnston

  • 6 Posts
  • 0 Reply Likes
The prefs must have reset as the organiser came up with a setting dialogue when loading. I was just commenting that the instructions on that page you linked to were different to what actually happens on PSE9.
Photo of Paul Johnston

Paul Johnston

  • 6 Posts
  • 0 Reply Likes
Any ideas?
Photo of Paul Johnston

Paul Johnston

  • 6 Posts
  • 0 Reply Likes
I solved this temporarily by setting the loading program to run as administrator. That gives it the right credentials to launch the editor.

Hopefully there is a better fix though...

By the way I checked my preferences and they had been reset so this didn't have an effect. Something else afoot....
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
If you are having to Run as Administrator in order to launch Photoshop Elements, there is something going wrong with your permissions. Have you tried running in a new user account to see if that works without having to Run as Admin?
Photo of Elizabeth Dessi

Elizabeth Dessi

  • 3 Posts
  • 0 Reply Likes
I have JUST gotten this problem I think. When I go to open the program, and click "edit" everything disappears! I have tried different thing sfor about an hour, even uninstalling, and can't even uninstall because the popup claims I have something open. Organizer still opens though. Getting frustrated!
Photo of Regina Barnes

Regina Barnes

  • 6 Posts
  • 0 Reply Likes
I am having this same issue with the editor. Has anyone come up with a solution? I am trying to use this, but am so frustrated. Nothing on here helps me with my problem.
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
The problem with such behavior is that there is no one solution, because there is no one problem. Depending on the root cause, there will be a different resolution. Only through investigation and testing will a answer be found. See my post below for the general troubleshooting guide to perform standard tests and solutions.
Photo of stuart morgan

stuart morgan

  • 4 Posts
  • 1 Reply Like
no it hasn't been sorted ! its been 6 months now and i haven't use the program, in the end i just gave up
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
How many of the suggestions listed here have you tried? Just resetting preferences? Did you uninstall and reinstall? (This worked for Elizabeth).

The problem here is that the behavior you are encountering is completely generic and can result from possibly hundreds of different root issues. Without more information, it's just a lot of shots in the dark.

For a more complete list of possible solutions, check here:
Troubleshoot system errors, freezes | Windows | Adobe software
Photo of Elizabeth Dessi

Elizabeth Dessi

  • 3 Posts
  • 0 Reply Likes
I finally uninstalled and reinstalled. It cleared it up, but hoping whatever triggered it won't come back.
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
Good point, but if reinstalling it fixed the issue, this suggests that one of the files within the application was damaged in some way. Why files become corrupted on hard drives at the fault of no one but simple physics (hence the need to have backups because you NEVER know what will happen on your computer), it is also possible that software designed to protect your computer can sometimes actually mistakenly cause problems too. Make sure you security software is up to date with all the latest definitions.
Photo of Elizabeth Dessi

Elizabeth Dessi

  • 3 Posts
  • 0 Reply Likes
Brett, thanks for taking the time to answer. It's working good right now, and hopefully will stay that way!