Lightroom: Cannot delete missing photos in LR 4.3

  • 4
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
Cannot delete missing photos in LR4.3

Please try this:

1. Find missing photographs
2. Select All
3. Pick "delete photos" from the menu.
4. Nothing will happen!

We had a discussion here:
http://forums.adobe.com/message/49182...

This is probably newly formed LR 4.3 bug.
Photo of ivan.planinar

ivan.planinar

  • 106 Posts
  • 8 Reply Likes
  • sad

Posted 7 years ago

  • 4
Photo of Robert Peters

Robert Peters

  • 39 Posts
  • 15 Reply Likes
The same bug exists for OS X (10.8.2) on my MacBook Pro (retina) when I try to delete the missing image from the catalog. However, if I create a Quick Collection the deletion works from within the collection if I add the missing images to that collection.

I think a bit more thorough testing would have been nice.
Photo of Brett N

Brett N, Official Rep

  • 2260 Posts
  • 122 Reply Likes
Perhaps I'm missing something here, but this worked just fine for me. I selected an image at random, use the Show in Finder function, moved the file to the desktop, went back to Lightroom and the image was missing. I then deleted it (I've tried using simply the Delete key, right/Control+clicking and choosing Delete Photo, as well as using Photo > Delete Photo). Each time the image was removed from Lightroom.

Can you try this same test on your side to see if it works (that is force a file to be missing and then try deleting it). If that still fails, could you try creating a new catalog, importing a couple files, move them so they become missing, and then delete?
Photo of Robert Peters

Robert Peters

  • 39 Posts
  • 15 Reply Likes
Please read the post by the OP. The steps you must follow (which I just repeated with a new catalog) are:
(1) remove some files so that the "?" appears on the missing ones
(2) imagine these are missing in a large catalog and invoke Library>Find Missing Photos
When you try to delete the missing photo(s) from the catalog nothing happens.
Now add the missing photos to a Quick Collection and the deletion will work.
Photo of Brett N

Brett N, Official Rep

  • 2260 Posts
  • 122 Reply Likes
Thank you for the clarifying point. So the problem is specific to the Missing Photographs collection. Now I see what you are talking about. However, I don't see your workaround working. After adding the photos to the Quick Collection, the option to delete the photos should turn to "Remove from Quick Collection" which will not delete them from the catalog. What should work instead is to flag the files as Rejected and then use the Delete Rejected Photos option. This should work even from the Missing Photographs collection.
Photo of Robert Peters

Robert Peters

  • 39 Posts
  • 15 Reply Likes
Add the photos in the Missing Photographs collection to a Quick Collection and you can delete them.
Photo of ivan.planinar

ivan.planinar

  • 106 Posts
  • 8 Reply Likes
Is anyone of the authorities here to confirm this, please?
Photo of Brett N

Brett N, Official Rep

  • 2260 Posts
  • 122 Reply Likes
Tested, not able to confirm as it works on my end. Refer to above reply for testing.
Photo of Brett N

Brett N, Official Rep

  • 2260 Posts
  • 122 Reply Likes
Re-tested - confirmed. Bug logged.
Photo of ivan.planinar

ivan.planinar

  • 106 Posts
  • 8 Reply Likes
Glad you were able to confirm. And thanks to Robert Peters for assisting!
Photo of Rick Huntsman

Rick Huntsman

  • 1 Post
  • 0 Reply Likes
select all then alt delete worked fine...all gone.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
Official Response
This was fixed in Lightroom 5 or later.